Outbound proxy: Use of fromdomain for register

Is there no way to configure an outbound proxy when registering? I am trying to use proxy.siprovider.com as the outbound proxy and mydomain.com as my fromdomain. However, the fromdomain only seems to take effect for INVITEs, not for REGISTERs.

I have the following configuration:

[general]
port = 5060 ; Port to bind to
bindaddr = 10.0.1.1 ; Address to bind SIP channel to
context = sip-external ; Default context for incoming calls
tos=reliability ; IP QoS parameter, either keyword or value
maxexpirey=180 ; Max length of incoming registration we allow
defaultexpirey=160 ; Default length of incoming/outoing registration
disallow=all ; Disallow all codecs
allow=ulaw ; Allow codecs in order of preference

register => myname:mypassword@mysipprovider.com

[mysipprovider.com]
type=peer
insecure=yes
insecure=very
host=proxy.sipprovider.com
fromdomain=mydomain.com
username=myname
secret=mypassword
canreinvite=no

The REGISTER looks like:

REGISTER sip:mydomain.com
Via: …
From: sip:myname@proxy.sipprovider.com:tag=…
To: sip:myname@proxy.sipprovider.com

I want the REGISTER to look like:

REGISTER sip:mydomain.com
Via: …
From: sip:myname@mydomain.com:tag=…
To: sip:myname@mydomain.com

Any insight would be greatly appreciated.

Thanks, Michael

I have the same problem, could anyone PLEASE give us some feedback.

Let us say, my SIP URI is user@x.y and the proxy I want to use is 192.168.1.53 so I configured the ‘fromdomain’ and ‘host’ settings to be ‘x.y’ and the ‘outboundproxy’ to be 192.168.1.53. Furthermore I use the following register line:
register=user:password:authuser@x.y:5060/user

I am not sure this will help you, but there is a parameter outboundproxy= in the sip.conf definition.

Anyone found a solution for this?

My voip provider resquires an outbound proxy for registration, can’t find a way to register …

Did you look at the last post on this topic before posting?

Yes, and i tried that in my sip.conf

But it seems that it ignores that, i’m using a packet sniffer and it alway tries do register without proxy …

I even restarted the server but it still trying to connect without proxy …

What version of Asterisk are you using?

Who are you registering with?

Some providers seems to not work properly with * (such as i2telecom).

Aharon

I’m using Asterisknow latest release.

And my provider is telepac (it’s a portuguese telecom):

sip: voip.telepac.pt
outbound proxy: proxy.voip.telepac.pt:5070

Thanks

Not promising anything, but if you post a snippet of your sip.conf containing all the relevant info, I will try to help you.