Options and PJSIP_wizard help

Hey guys

Sorry this maybe super easy for you guys but i’m a little suck and close to pulling my hair out

so i have set up asterisk i have done i TCPdump on the asterisk server itself and i can see the options SIP packets coming in but asterisk is not replying to them here’s my config

PJ_wizard set up below

[trusted-peer]

endpoint/context = peer_context
remote_hosts = peering.2talk.co.nz
sends_registrations = no
accepts_registrations = no
sends_auth = no
accepts_auth = no

oh and its trusted based off my IP so off reading reg and auths can be no i think thats right
Ext below
[general]

[globals]

Phone_A01=PJSIP/0000f30A0A01
Phone_A=PJSIP/Softphone_A
Phone_B02=PJSIP/0000f30B0B02
Phone_B=PJSIP/Softphone_B

;exturnal calls to carrier

TOLL=PJSIP/trusted-peer
LOCAL=PJSIP/${TOLL}

[sets]
include => external

exten => 100, 1, Dial(${Phone_A01},10,m)

exten => 101, 1, Dial(${Phone_B02},10,m)
same => n,Playback(vm-nobodyavail)
same => n, hangup()

exten => 102, 1, Dial(${Phone_A})

exten => 103, 1, Dial(${Phone_B})

exten => 200, 1, Answer()
same => n, Playback(hello-world)
same => n, Hangup()
exten => 201, 1, Goto(TestMenu,start,1) ;add this to the end of the [sets] con

exten => usrname,1,Hangup ; to reply to options with ok and not 404

;Varaiable Concatenation

exten => 204,1,Answer()
same => n,Answer()
same => n,Set(ONETWO=12)
same => n,Set(THREEFOUR=34)
same => n,SayDigits({ONETWO}{THREEFOUR}) ; like this
same => n,wait(0.2)
same => n,Set(NOTFIVE={THREEFOUR}{ONETWO})
same => n,SayNumber({NOTFIVE}) same => n,wait(0.2) same => n,SayDigits(2{ONETWO}3)

[TestMenu]
exten => start,1,Answer()
same => n,Background(enter-ext-of-person)
same => n,WaitExten(5) ; We always pass a time argument to WaitExten()

exten => 1,1, Playback(digits/1)
same => n,Goto(TestMenu,start,1)

exten => 2,1, Playback(digits/2)
same => n,Goto(TestMenu,start,1)

exten => 3,1,Dial(${Phone_A},10)
same => n,Playback(vm-nobodyavail)
same => n,Hangup()

exten => 4,1,Dial(${Phone_A01})
same => n,Playback(vm-nobodyavail)
same => n,Hangup()

exten => i,1, Playback(pbx-invalid)
same => n,Goto(TestMenu,start,1)

exten => t,1,Playback(please-try-again)
same => n,Goto(TestMenu,start,1)

[external]

exten => _X.*,1,Dial(${TOLL})

[to-pstn]

;strip off NDD prefix, add country code, and send
exten => _0X.,1,Dial({TOLL}/64>{EXTEN:1})

;strip off IDD prefix and send
exten => _00X,1,Dial({LOCAL}/{EXTEN:2}) ; country code plex phone number

;Emergency Dialing
exten => 11X,1,Dial({LOCAL}/{EXTEN})

sorry alot of rubbish is there just playing around and testing

and pjsip.conf file

[transport-udp]

type=transport
protocol=udp
bind=0.0.0.0
local_net=10.0.0.0/24 ; internal network
external_media_address=my ip thats a no;External IP address to us in RTP handling
external_signalinig_address=my ip thats a now =D;External IP address for SIP signalling

[transport-tls]

type=transport
protocol=tls
bind=0.0.0.0
cert_file=/home/asterisk/cert/asterisk.alexosaurous.co.nz.cer
priv_key_file=/home/asterisk/cert/asterisk.alexosaurous.co.nz.key

thank you so much for any time and help someone can give me

I’d expect Asterisk to reply if it received them, and there were any way of getting back to the sender. It would send an error response.

Are they being logged by Asterisk, or only by tcpdump? Note the former sees them before the firewall. Also, are they arriving on a transport that is configured.

tcpdump is only seeing them, i have turned off my firewall as i was thinking that maybe stopping it as i was only seeing them in my tcpdump but no luck there i also found that asterisk was not listening on 5060 so i’m thinking my pjsip.conf is wrong maybe

doing some more googling on this now =D any help always welcome lol thank you david551 by the way for taking the time to help

UPDATE lol it was my pjsip.conf file

local_net=10.0.0.0/24 ; internal network
external_media_address=my ip thats a no;External IP address to us in RTP handling
external_signalinig_address=my ip thats a now =D;External IP address for SIP signalling

i just need to work out how to do this bit above as thats the bit that stopped it listening on port 5060 so something wrong there, so i was reading external_media and external_sugnalining needed if behind nat is that not the case

or i’m i just doing it wrong i was putting = my external IP in both options