One-way audio LYNC 2013 with Asterisk Gateway over NAT

Hi Please help with troubleshooting an issue with Asterisk serving as a gateway for Lync 2013. Problem is there is no audio from Lync to Asterisk but Lync extension have audio from Asterisk. The Lync and Asterisk servers are in different networks. The Lync has a public IP and is at a remote datacenter and the Asterisk is in the office LAN. The Asterisk is being NATed out to talk to the Lync 2013. Call ring even when Lync user calls external numbers through the Asterisk gateway the calls connect but the Audio from the Lync is not heard on the other side.

My config

On Asterisk I have a trunk to the Lync with the following outgoing settings

trunk name connect-with-lync

Incoming Settings

trunk name from-lync

Then the file sip_general_custom.conf, has the configuration below:

bindport=5060 ; this configuration define the listening port asterisk
notifyhold = yes

Please help dnt know what to look for anymore and google hasnt hellped this far
This is the document I followed … ix-part-2/

You have some parameters that are either obsolete and possibly unsupported, or you are using an obsolete version of Asterisk.

Whilst Lync requires insecure=port, because of the TCP, you should not need insecure=invite, and I believe current versions reject insecure=very.

It is meaningless to have two peers with the same host address. You only need one peer to cover both incoming and outgoing.

allowguest=yes is dangerous (although default) and can confuse the issue.

I would check for firewalls blocking the RTP.

Thanks David I am on Asterisk 11.4. I have removed all incoming settings on the Trunk. I had this doing trial and error. I have removed insecure=very and set allowguest=no as per your advice.
On the router I am forwarding port 5060 to the PBX I have a feeling there are other ports I need to forward. Please advise on the RTP. There is no firewall as such between the devices just the router forwarding port 5060. Is there a particular port range I need to forward for RTP?

We found you need insecure=port for Lync, because TCP connection originate from different port numbers.

You need to forward incoming UDP port numbers in the range specified in rtp.conf and outgoing ones in the range specified on the Lync media server.

I see, will try it out and let you know. Thanks for the help

No luck. The router is allowing RTP traffic through to the asterisk. But still no audio coming from the Lync server. Traffic from the Asterisk going out to the Lync server is all allowed

Is Asterisk sending a valid address for itself in the c line of the SDP?

Hi David.

Where would I check if Asterisk sending a valid address for itself in the c line of the SDP? Sorry am not an advanced Asterisk user. And Sorry for the delayed response I have been away from work for the past two weeks.



sip set debug on

or a wireshark/tcpdump trace of the protocol.

I have c=IN IP4 This is my Local LAN private IP where the PBX sits. Am jus guessing this should be the Public IP that the Lync 2013 uses to reach the Asterisk instead of the local priavte IP. Confirm if am correct and how do I change the asterisk to give the public IP.

o=root 1903017938 1903017938 IN IP4
s=Asterisk PBX 11.4.0
c=IN IP4
t=0 0
m=audio 12234 RTP/AVP 0 8 3 101
a=rtpmap:0 PCMU/8000
a=rtpmap:8 PCMA/8000
a=rtpmap:3 GSM/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16

I have managed to get this to work by adding by adding the following lines on the sip_general_custom.conf


Thanks David for helping me out