Notice: Received SIP subscribe for peer without mailbox

One of the users on our 11.3.0 installation keeps getting the following message that is really odd:

NOTICE[25980]: chan_sip.c:27566 handle_request_subscribe: Received SIP subscribe for peer without mailbox: XXXXX

There are 3 reasons why this is odd, first of all, the user is configured exactly like every other user; secondly, all other users work correctly without an error; finally, voicemail does work for the user.

When I run ‘voicemail show users for default’ (default is where the user comes under), I get the following output for the user:

=== Mailbox ...
=== ==> uniqueid: X
=== ==> context: default
=== ==> mailbox: XXXXX
=== ==> password: XXXX
=== ==> fullname: John Doe
=== ==> email:
=== ==> language: en
=== ==> stamp: 0000-00-00 00:00:00

Please note that I have masked the uniqueid, mailbox, password, fullname and email fields. Also note the stamp field that has never updated. Then I run ‘sip show peer XXXXX’ and get

  Mailbox      : 

All other users have their mailbox number showing here, I have even specified the mailbox in the database field however this does not change.

I have no database issues, all other mailboxes update and are working perfectly.

I’m concerned there is a bigger underlying problem and that I may get the notification where voicemail actually doesn’t work so it is important to me that I fix this issue.

Any ideas?


Since you mentioned database, go and make the query for show all fields of that peer if the mailbox data is empty then update it.

Thanks for the reply navaismo.
I just went to check on the database yet again and noticed that the problem mysteriously disappeared. I made no changes at all yet it is now working 100% without any messages regarding the mailbox.

The only thing that happened between then and now was a reboot of the server, I had done this a number of times before posting so I’m at a loss as to what the actual issue was.