Not able to Call

I installed asterisk in my ubuntu-8.10 like this:
“aptitude install asterisk”

this is my sip configuration
[futurelabs]
type=friend
bindport=5060
context=from-sip
;host=192.168.100.168
callerid=futurelabs

[subba]
type=friend
context=from-sip
;host=192.168.100.168
callerid=subba
bindport=5061

this is my extensions(/etc/asterisk/extensions.conf) configuration

[futurelabs]
exten => 301,1,Dial(SIP/futurelabs)

[subba]
exten => 302,1,Dial(SIP/subba)

but Iam not able to call from one phone to other phone
also Iam getting following error while calling

[Jan 31 12:52:43] NOTICE[7683]: chan_sip.c:15236 handle_request_register: Registration from ‘futurelabs sip:futurelabs@192.168.100.100’ failed for ‘192.168.100.168’ - Peer is not supposed to register
Scheduling destruction of SIP dialog ‘75ae0267-bae93bea@192.168.100.16’ in 32000 ms (Method: REGISTER)
[Jan 31 12:52:43] ERROR[7683]: chan_sip.c:8718 register_verify: Peer ‘subba’ is trying to register, but not configured as host=dynamic
[Jan 31 12:52:43] NOTICE[7683]: chan_sip.c:15236 handle_request_register: Registration from ‘subba sip:subba@192.168.100.100’ failed for ‘192.168.100.168’ - Peer is not supposed to register
Really destroying SIP dialog ‘75ae0267-bae93bea@192.168.100.16’ Method: REGISTER

any help!

thanks,
Subhan

I’m assuming that [futurelabs] and [subba] are your phones.

  1. The bindport= setting should not be there. This is defined once for your Asterisk SIP config and should be in a the [general] section. You don’t really need to define it, anyway, it defaults to 5060.

  2. Phones can be defined as type=user, not friend.

  3. You’ll need to define a username and secret (i.e. password) for each phone and ensure these settings are correct in the phones themselves.

  4. Your extensions.conf is incorrect, calls from both phones will come into the [from-sip] context, which you have not defined.

Have a read of Voip-Info’s page on SIP configuration.