No video in Asterisk w/ PJSIP

I’ve been struggling over this for a few days. I’m trying to setup a videocall between two Grandstreams (tried a few other devices/clients as well) but I can’t get the video to work.

The 2 endpoints in pjsip.conf only have the following options since the “videosupport” tag is no longer supported.


SIP traffic showing that H323 is requested.

o=241040 8000 8000 IN IP4
s=SIP Call
c=IN IP4
t=0 0
m=audio 5004 RTP/AVP 0 8 4 18 9 3 101
a=rtpmap:0 PCMU/8000
a=rtpmap:8 PCMA/8000
a=rtpmap:4 G723/8000
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:9 G722/8000
a=rtpmap:3 GSM/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-15
m=video 5006 RTP/AVP 99 100 34
a=rtpmap:99 H264/90000
a=fmtp:99 profile-level-id=428014; packetization-mode=1
a=rtpmap:100 H263-1998/90000
a=fmtp:100 CIF=2; QCIF=2
a=rtpmap:34 H263/90000
a=fmtp:34 CIF=2; QCIF=2

“core show codecs” seems to list various videocodecs just fine.

30 image      png (PNG Image)
5 audio     g726 (G.726 RFC3551)
3 audio     alaw (G.711 a-law)
1 audio     g723 (G.723.1)
19 audio    speex (SpeeX)
20 audio    speex (SpeeX 16khz)
21 audio    speex (SpeeX 32khz)
23 audio     g722 (G722)
31 video     h261 (H.261 video)
32 video     h263 (H.263 video)
7 audio    adpcm (Dialogic ADPCM)
24 audio   siren7 (ITU G.722.1 (Siren7, licensed from Polycom))
27 audio     g719 (ITU G.719)
33 video    h263p (H.263+ video)
34 video     h264 (H.264 video)

However, it appears that PJSIP is not capable of sending any kind of video?

“core show channeltype PJSIP”

-- Info about channel driver: PJSIP --
Device State: yes
Indication: yes
Transfer : yes
Capabilities: (g723|ulaw|alaw|gsm|g726|g726aal2|adpcm|slin|slin|slin|slin|slin|slin|slin|slin|slin|lpc10|g729|speex|speex|speex|ilbc|g722|siren7|siren14|testlaw|g719|opus)
Digit Begin: yes
Digit End: yes
Send HTML : no
Image Support: no
Text Support: yes

Can someone please clarify? I know there is a “disable-video” argument during configure of PJSIP, but I’ve tried it with and without.

I am facing the same issue.
Can anyone suggest fix ?