No user able to register with remote asterisk server

Hello dear.

i have been using asterisk on my local network
now i have setup it on a dedicated server (remote location)
the server runs CENOS fresh install
asterisk =1.4.30
i have edited sip.conf,users.conf,extensions.conf & IAX

the problem is that no one of users is able to register with the server using ip or domain
IAX trunks are not even registering

asterisk console does not display anything about the registering event.
i guess reg. request not reaching to asterisk server

i use X-lite for testing - it says registration error 408- time out…
the users can be anywhere…
i tried externip etc etc nothing working

i am running out of time please help…
comments appreciated…

Guys PLease help
below is the sip.conf

port = 5060
bindaddr =
qualify = no
disable = all
allow = alaw
allow = ulaw
dtmfmode = rfc2833

srvlookup = yes

users are defined in users.conf
fullname = New User
userbase = 6000
hasvoicemail = yes
vmsecret = 1234
hassip = yes
hasiax = yes
hasmanager = no
callwaiting = yes
threewaycalling = yes
callwaitingcallerid = yes
transfer = yes
canpark = yes
cancallforward = yes
callreturn = yes
callgroup = 1
pickupgroup = 1
vmexten = 6666

username = 6000
transfer = yes
mailbox = 6000
call-limit = 100
type = peer
fullname = john
registersip = no
host = dynamic
callgroup = 1
type = peer
context = DLPN_local
cid_number = 6000
hasvoicemail = yes
vmsecret = 6666
email =
threewaycalling = no
hasdirectory = no
callwaiting = no
hasmanager = no
hasagent = no
hassip = yes
hasiax = yes
secret = 6000
nat = yes
canreinvite = no
dtmfmode = auto
insecure = no
pickupgroup = 1
autoprov = no
label =
macaddress =
linenumber = 1
disallow = all
allow = ulaw,alaw,g726,g729


I think you should start with a simpler [6000] context. Something like:


…you also indicated peer; that might be your problem.

and by the way disable=all should be replaced with disallow=all in the [general] section.

After you simplify the context as suggested above. Please be descriptive about the environment of the server. NAT? SELinux? Other FireWall? If the network looks good try… sip set debug peer XXXX <- replace the name of the peer you are trying to fix.

Thanks for giving it a look
sip set debug 6000 returns “Unable to get IP address of peer ‘6000’”

When xlite shows registering… nothing displays about the registration request.

the server is a remote hosted dedicated server with no firewals…
i think registration request does not reaches asterisk
do i need to setup my domain name in asterisk anywhere?

it’s "sip set debug ip " or as suggested above: sip set debug peer XXXX

SElinux= disabled , type= targetted… no firewalls are setup.
port 5060 open used by asterisk.
debug for ip returns "enabled for ip"
do i need to tell asterisk that domain is “”? or any thing else if yes then how?

Are you sure you have XLite set up correctly?

mmmm …the same config files were tested fine on other server. these are the backup files already tested

changed to Asterisk …still not fixed ,same isssue prevails

SOLVED----- Turn off IPtables or add 5060 to iptables as accpet

to turn off iptables run
service iptables stop
chkconfig iptables off