No sound in the outbound

#1

Hi.

In Asterisk 13, I configured inbound and outbound.
There is no sound on outbound.

I’m connected by dialing an outside phone number, but there is no sound from both parties.
Strangely, the sound comes out in the inbound.

Do you have any advice?

  • Using aws for Asterisk.
  • The Sip client uses pjsip.

My settings:

sip.conf

[general]
maxexpirey=3600
defaultexpirey=3600
context=default
port=15060
bindport=15060
bindaddr=0.0.0.0
srvlookup=yes
callcounter=yes
rtcachefriends=yes
allowguest=no
disallow=all
allow=opus
allow=ulaw
allow=alaw
allow=gsm
language=ja
externip=3.112.32.84
localnet=172.31.29.32/255.255.0.0
;nat=force_rport,comedia
nat=yes
udpbindaddr=0.0.0.0
tcpbindaddr=0.0.0.0
rtptimeout=1
rtpholdtimeout=300
session-timers=originate
session-expires=3600
session-minse=300
session-refresher=uac


[naisen](!)
type=friend
secret=xxxxxxxxxxxxxxxxxxxxxxxxx
canreinvite=no
host=dynamic
dtmfmode=rfc2833
callgroup=1
pickupgroup=1
context=default
qualify=yes

[hibiki_201](naisen)
[hibiki_202](naisen)
[hibiki_203](naisen)
[hibiki_204](naisen)
[hibiki_205](naisen)

[fusion-smart1]
type=friend
username=58660839
fromuser=58660839
secret=xxxxxxxxxxxxxxxxxxxx
host=smart.0038.net
fromdomain=smart.0038.net
context=default
insecure=port,invite
canreinvite=no
disallow=all
allow=ulaw
allow=alaw
;dtmfmode=inband
dtmfmode=rfc2833,info
;nat=never
nat=yes
qualify=yes
allowguest=yes

extensions.conf

[general]
writeprotect=no
priorityjumping=no

[globals]
USEVOICEMAIL=YES
SPEAKINGCLOCK=317
ECHOTEST=333

[default]

; Speaking Clock
exten => ${SPEAKINGCLOCK},1,Answer()
exten => ${SPEAKINGCLOCK},n,Wait(1)
exten => ${SPEAKINGCLOCK},n,Set(FutureTime=$[${EPOCH} + 5])
exten => ${SPEAKINGCLOCK},n,SayUnixTime(${FutureTime},Japan,YbdAPHM)
exten => ${SPEAKINGCLOCK},n,Playback(jp-desu)
exten => ${SPEAKINGCLOCK},n,playback(beep)
exten => ${SPEAKINGCLOCK},n,Hangup

; Echo Test
exten => ${ECHOTEST},1,Answer
exten => ${ECHOTEST},n,Wait(1)
exten => ${ECHOTEST},n,Playback(demo-echotest)
exten => ${ECHOTEST},n,Playback(beep)
exten => ${ECHOTEST},n,Echo
exten => ${ECHOTEST},n,Playback(demo-echodone)
exten => ${ECHOTEST},n,Playback(vm-goodbye)

; Local SIP phones hibiki_201-209
exten => _hibiki_2XZ,1,GotoIf($["${USEVOICEMAIL}"="YES"]?use-vm)
exten => _hibiki_2XZ,n,Dial(SIP/${EXTEN},20,tT)
exten => _hibiki_2XZ,n,Hangup
exten => _hibiki_2XZ,n(use-vm),Dial(SIP/${EXTEN},20,tTwW)
exten => _hibiki_2XZ,n,NoOp(${DIALSTATUS})
exten => _hibiki_2XZ,n,GotoIf($["${DIALSTATUS}"="BUSY"]?vm-rec)
exten => _hibiki_2XZ,n,GotoIf($["${DIALSTATUS}"="NOANSWER"]?vm-rec)
exten => _hibiki_2XZ,n,GotoIf($["${DIALSTATUS}"="CHANUNAVAIL"]?vm-rec)
exten => _hibiki_2XZ,n,Hangup
exten => _hibiki_2XZ,n(vm-rec),Answer()
exten => _hibiki_2XZ,n,Wait(1)
exten => _hibiki_2XZ,n,Voicemail(${EXTEN})
exten => _hibiki_2XZ,n,Hangup

exten => 58660839,1,noop(inbound)
   same => n,dial(SIP/hibiki_201,,tTwW)
   same => n,hangup

exten => _0.,1,noop(outbound)
   same => n,dial(SIP/fusion-smart1/${EXTEN})
   same => n,hangup
0 Likes

#2

Double check the router’s firewall and NAT settings and the OSes firewall settings.

set rtp debug on to see if the problem is inbound or outbound.

Use sip set debug on and confirm that the correct addresses are being sent in the SDP. Also confirm that the three way handshake is completing.

0 Likes