No ringback tone in IAX extension if call goes to SIP trunk

I have several IAX2 extensions in a Asterisk 1.6.2 PBX.

I’ve noticed that if a call from those IAX2 extensions is placed though a SIP trunk there’s no ringback tone. That’s the only problem, the call is answered, the callee hears the ring sound, the communication is perfect. It’s just that there is no ringback tone in the meanwhile. The problem is reproducible either with local and remote extension, and either with hardphone (Atcom 610-R) and softphone (Zoiper) iax extensions

This just happens if the call is placed through a SIP trunk. When the call is to another extension (SIP or IAX) every thing is OK. If the call goes through the ISDN trunk everything is right.

Notice that if the call is originated in a SIP extension and goes through the same trunk, then the ringback tone sounds rightly; just happens if the caller uses one of the IAX2 extensions.

I believe that this is a real problem for the users of those extensions, because the caller isn’t able to know if the call is ringing in the callee end; and the situation goes worse if the callee takes long to answer

I’ll be very thankful if anyone can give me hints to debug this nasty problem

Thanks in advance

The trunk is probably using in band progress, which now requires that the dialplan explicitly use the Progress() application.

I think the issue may be to do with avoiding an early start to networm billing in some cases.

thanks David55

I’ve tried to place a Progress() command before the Dial() command in the dialplan for the dialout trunks without succeed. Probably I’m misunderstanding your hints. My knowledge of asterisk internals is quite basic.

So far I’ve already tried to use progressinband=yes in the trunk’s sip settings with no effect

I’ve rechecked that this is just happening between IAX extensions and one SIP provider. Other SIP providers are working rightly.

As noted in my former post, the calls from SIP phones work as expected with ringback tone with all the SIP providers I can test.

Thanks in advance

My next guess would be that you’ve hit the reason why Progress() has to be used, but a case where Progress isn’t supported. I’d try explicitly using Ringing, and not allowing inband progress, as, maybe the network isn’t prepared to handle in band progress, but won’t generate ringback without being told to.

Hi again David55,

The ringing() command hides the problem with that provider and now my users will be happy again :smiley:

Many thanks

Last question

It’s possible to add in the dialplan some kind of checking to see if Progress() is supported and if not run Ringing()?

Thanks in advance

No. Because the limitations may be imposed several hops downstream.

The problem with progress, is that, if you hit a chargeable network, it allows you to do recorded announcement services without the caller being billed, so there is a good chance that you will have problems with it if you hit the PSTN.

Could you post the solution instead of just a ringing()? People will not understand how to fix it

The version of Asterisk referred to here is obsolete.

However, if people need fully worked out solutions, they should not be using a peer support forum; they should be paying an appropriately qualified consultant.

I am using Asterisk 13 but got the same problem. I know the 1.8 is obsoleted a long time. I guess it is a matter of a minute fix. How much will it be for one-minute pay support?

ringback is probably inband, in which case you need to call Progress().