No ringback for incoming calls

Hi all,

Installation of my new server is progression well (asterisk 20.5). I just noticed today an issue related to incoming calls. There is no ringback :-(.

Here is the dialplan for incoming calls :

[common-external](!)
exten => s,1,NoOp(${CONTEXT})
same => n,NoOp(${CALLERID(num)})
same => n,Answer()
same => n,Set(ARRAY(admin_name,admin_context)=${ATTENDANT_IS_ADMIN(${CALLERID(num)})})
same => n,GotoIf($["${admin_name}" = ""]?get-message-type)
same => n,Playback(fr/flexia/${admin_name})
same => n,Gosub(service,s,1(${CONTEXT}))
same => n,Goto(ring)
same => n(get-message-type),NoOp();Set(message_type=${ATTENDANT_GET_MESSAGE_TYPE(${CONTEXT})})
same => n,GotoIf($["${message_type}" = ""]?ring)
same => n,Playback(fr/flexia/${message_type}-message)
same => n,GotoIf(${REGEX("^exceptional-.*$" ${message_type})}?emergency)
same => n,Playback(fr/flexia/schedules-${CONTEXT})
same => n(emergency),Playback(fr/flexia/emergency-numbers-${CONTEXT})
same => n,Hangup()
same => n(ring),Set(endpoints_list=${HOTDESK_GET_ENDPOINTS_LIST(${CONTEXT})})
same => n,Dial(${endpoints_list},10,b(handler^addHeaderExternal^1))
same => n,Playback(fr/flexia/wait-1)
same => n,Dial(${endpoints_list},25,b(handler^addHeaderExternal^1))
same => n(wait2),Background(fr/flexia/wait-2)
same => n,WaitExten(30)
exten => 1,1,Dial(${endpoints_list},,b(handler^addHeaderExternal^1))
exten => 2,1,VoiceMail(${${CONTEXT}+"-mailbox@flexia"})
same => n,Hangup()
exten => i,1,Goto(attente2)
exten => i,n,Hangup()
exten => t,n,Hangup()

I tried several options for the Dial application :

Dial(…,r) => no effect
Dial(…,R) => no effect
Dial(…,rm) => music on hold is working (quality is very poor).

Playback application in the dialplan works without any issue.

I tried also to play with inband_progress in pjsip.cong but also without success.

When looking in pjsip logger, the only place where I can find a 180 Ringing is here :

[2023-11-23 19:08:14] <--- Received SIP response (675 bytes) from UDP:91.179.112.248:5060 --->
[2023-11-23 19:08:14] SIP/2.0 180 Ringing
[2023-11-23 19:08:14] Via: SIP/2.0/UDP XX.XX.XX.XX:12345;rport=56278;branch=z9hG4bKPj4a6de03f-2b56-4600-be2d-ab6a0f00c4fa
[2023-11-23 19:08:14] Max-Forwards: 70
[2023-11-23 19:08:14] From: "Unknown" <sip:Unknown@172.31.6.118>;tag=e687dae2-76dc-42e3-b5bb-4a8dec0b3e96
[2023-11-23 19:08:14] To: <sip:vielsalm-m400-1@91.179.112.248;line=7435>;tag=qfkx79v12.iki.
[2023-11-23 19:08:14] Call-ID: 4398c167-be94-4a19-b2c1-fffa24fa6e7c
[2023-11-23 19:08:14] CSeq: 29990 INVITE
[2023-11-23 19:08:14] Contact: <sip:vielsalm-m400-1@192.168.2.165;line=7435>
[2023-11-23 19:08:14] Allow: INVITE, CANCEL, BYE, ACK, REGISTER, OPTIONS, REFER, SUBSCRIBE, NOTIFY, MESSAGE, INFO, PRACK, UPDATE
[2023-11-23 19:08:14] Allow-Events: talk,hold
[2023-11-23 19:08:14] Require: 100rel
[2023-11-23 19:08:14] RSeq: 39930
[2023-11-23 19:08:14] User-Agent: snomM400/06.70.0202  (MAC=000413D11E6B; SER= 00000; HW=3)
[2023-11-23 19:08:14] Content-Length: 0

Any idea that could help to unblock ?

Thanks in advance for your help !

I think answered calls always get inband progress.

Os endpoints_list degenerate (single contact from single endpoint)? If not, the remote ringing won’t be passed through, but r should still work

Are there any commas between r and b? There should not be.

Hi David,

Thanks for your answer.

inband_progress is set to no by default it seems (https://github.com/asterisk/asterisk/blob/master/configs/samples/pjsip.conf.sample)

Here is the value of endpoints_list=PJSIP/vielsalm-m400-1 (dynamic value, can have several endpoints linked to implementation of hotdesking).

There is no commas between r & b…

Perhaps I should check with provider if there is something specific at his side.

Regards

I’m not sure my point was clear. Once you answer a call, there is no way, in SIP, of signalling ringback, other than as inband audio.

I updated inband_progress=yes for all endpoints but without success

As I said, that would only make any difference if you hadn’t answered the call. Once you answer the call Asterisk has to use inband regardless of the setting.

Are you using a codec in pass through mode? Audio tones are always generated as signed linear, so have to be transcoded.

Finally the solution is really… stupid.

I decided to start from a “blank” installation without any configuration files and to add them only when needed.

Problem is that I never added the file : indications.conf

As soon as this one was added (copy/paste from sample folder), the ringback tone was available !

Thanks for your help david551 and sorry for the stupid mistake :wink:

By the way, is it a good practice to limit as much as possible the number of configuration files ?

For sure, it generates error messages when loading the system due to missing conf files…

Here is my list of files :

image

Thanks in advance (and again) for valuable feedback !

By the way, is it a good practice to limit as much as possible the number
of configuration files ?

I would say the answer is exactly the same as general security advice
regarding packages / applications / services on your machine - if you don’t
want something to be running, don’t have it installed.

For sure, it generates error messages when loading the system due to
missing conf files…

In that case I suspect you should also be editing /etc/asterisk/modules.conf
and preventing the modules whose configuration files you do not need from trying
to load.

Antony.

I do. I start with ‘autoload = no’ in modules.conf and only load the modules I need.

“Parts left out don’t get broke.”

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.