No PSTN calling with Wildcard TDM400P card and 2 FXO modules

Hello everyone,

I’m running asterisk 1.4.18 with zaptel

I can’t seem to get a SIP phone connected to asterisk to use the Wildcard card to make an outgoing call. All that happens is it says that it’s calling and then after a time claims that nobody picked up but in fact no call is ever made. I plug a normal phone into the cable which the card is using and I get a dial tone and can make calls no problem.

I think I have everything set up correctly but I guess I have done something wrong. Here is what the card says in dmesg:-

Module 0: Not installed
Module 1: Not installed
Module 2: Installed – AUTO FXO (UK mode)
Module 3: Installed – AUTO FXO (UK mode)
Found a Wildcard TDM: Wildcard TDM400P REV I (2 modules)

Then I run ztcfg -vvvv and get this :-

Zaptel Version:
Echo Canceller: MG2

Channel map:

Channel 03: FXS Kewlstart (Default) (Slaves: 03)
Channel 04: FXS Kewlstart (Default) (Slaves: 04)

2 channels to configure.

The asterisk log says this when I try to make the call:-

[Mar 12 13:59:56] VERBOSE[15778] logger.c: – Executing [01698385806@manual:1] Dial(“SIP/manual1-007ae0a0”, “Zap/G1/9w01698385806|20”) in new stack
[Mar 12 13:59:56] DEBUG[15778] chan_zap.c: Dialing ‘9w01698385806’
[Mar 12 13:59:56] DEBUG[15778] chan_zap.c: Deferring dialing…
[Mar 12 13:59:56] VERBOSE[15778] logger.c: – Called G1/9w01698385806
[Mar 12 14:00:16] VERBOSE[15778] logger.c: – Nobody picked up in 20000 ms
[Mar 12 14:00:16] VERBOSE[15778] logger.c: – Hungup ‘Zap/4-1’
[Mar 12 14:00:16] VERBOSE[15778] logger.c: == Auto fallthrough, channel ‘SIP/manual1-007ae0a0’ status is ‘NOANSWER’

I’m guessing that this deferring dialling message is my problem but I don’t know how to fix it. Here is my zaptel.conf

loadzone = uk

Here is my zapata.conf

channel => 3,4

And finally here is my extensions.conf

exten => _0[1-9].,1,Dial(Zap/G1/9w${EXTEN},20)

Thanks for any help you can provide.


The first thing I’d ask is, are you sure you plugged the lines into the correct ports on the card?

The fact that you hear dial tone only tells me that your analog line is in good working order. If it’s plugged into the wrong port on the card, the FXO card can’t use it.

Good question,

Just looked at the back of the machine and I have my two lines plugged into the two ports which are lit. I only have 2 FXO modules on this card so the other ports are unlit.


Hmmm… any particular reason they were installed on ports 3 and 4? Not on ports 1 and 2?

I don’t think it matters much, since the asterisk box is trying to dial out using port 4.

Try bridging an analog phone onto the line, and listening when you start a dial attempt. It might provide some clues.

Okay just tried doing it with a phone on the line. When I dial with the SIP phone I get two pop/click noises somewhat reminiscent of pulse dialling and then the dead line tone.

If I lift the handset on the phone and leave it off hook for about 6 seconds I get the dead line tone minus the popping. If I plug the phone into the line on it’s own none of this happens and it works normally.

As for the modules arrangement I bought the card with them pre-installed so I guess who ever fitted them decided he wanted to work in descending order :wink:

Take the card out. Mark one FXO card and swap the locations of the FXO cards. See if the problem goes away. If it does, put them back in the original spots. See if the problem returns.

You may simply have a bad FXO card.

Well as soon as I opened the case noticed a problem. I haven’t plugged in the molex power adapter for the card. I guess that would do it. Now I just have to find a splitter as I don’t have any power cables left in this machine.

Thanks for your help dufus and I’ll post back to confirm that this worked. Looks like I’m the dufus :wink:

Happens to the best of us. :smile:

Hope it turns out ok.

The Molex is for FXS ports not FXO, What are you connected to ?is it a PBX as you are inserting a 9 ?

I would drop the w from the dialplan and test it then and change the 20 to 120 or so.

Also what does zttool show for the ports.


Ah okay, maybe thats why I didn’t plug it in originally then.

Just noticed this in dmesg after the reboot. Not sure if I saw this before.

irq 11: nobody cared (try booting with the “irqpoll” option)
Pid: 3131, comm: insmod Not tainted #3

Call Trace:
[] __report_bad_irq+0x30/0x7d
[] note_interrupt+0x217/0x258
[] handle_fasteoi_irq+0xa9/0xd1
[] call_softirq+0x1c/0x28
[] do_IRQ+0x6f/0xd8
[] ret_from_intr+0x0/0xa
[] :wctdm:wctdm_init_one+0x53c/0xf6b
[] :wctdm:wctdm_init_one+0x4d5/0xf6b
[] pci_device_probe+0xe9/0x156
[] driver_probe_device+0xf6/0x17f
[] __driver_attach+0x0/0x93
[] __driver_attach+0x5a/0x93
[] bus_for_each_dev+0x43/0x6e
[] bus_add_driver+0x77/0x1be
[] __pci_register_driver+0x58/0x8a
[] :wctdm:wctdm_init+0xcd/0xe0
[] sys_init_module+0x171d/0x185d
[] system_call+0x7e/0x83

[] (wctdm_interrupt+0x0/0xb18 [wctdm])
Disabling IRQ #11
Module 0: Not installed
Module 1: Not installed
Module 2: Installed – AUTO FXO (UK mode)
Module 3: Installed – AUTO FXO (UK mode)
Found a Wildcard TDM: Wildcard TDM400P REV I (2 modules)

Some kind of apic problem perhaps? The machine is a HP DL145 G2 if that makes any difference.

I don’t seem to have zttool, is it a normal part of the zaptel package?

Just tried a test call with the timeout set to 120, got the same result in the log except it nows says that nobody picked up in 120000 ms.

Sorry just realised I didn’t answer your question. We have an ISDN T1 line which we are plugging into via some kind of ISDN switch which breaks this T1 up into normal analogue lines.


[quote]ISDN T1 line[/quote] hopefuly E1 as you say you are in UK.

What does Zttool say ? it will show if the lines are installed and OK.

So do you need the 9 to dial out from the gateway ? what make of gateway is it ?

Quite correct, it is in fact an E1. The 9 is required for dialling out, this piece of ISDN equipment has SDX business systems written on it and has 5 units installed which are labelled from left to right AL-0-16, ALOG 0/16/0, E-PRI-30, DSLC 8 and CPU-X. I have no idea what any of this is or does as all my previous installations have been VOIP only.

Zttool isn’t installed which is strange as I compiled everything from source the usual way. zttool.c is in the directory but doesn’t seem to be compiled with a normal ./configure, make, make install.

Ok so its an old index. you definately dont need the w after the 9, just dial the whole number in one go.

How are you connecting to the card ? if its a lead from a BT socket. then make sure the lead is correct. IE

BT plug RJ11 TDM in Asterisk

2 ---------------3
5 ---------------4


The ISDN equipment is wired into a standard RJ45 patch panel and the telephone engineer who originally installed the equipment provided RJ45 to RJ11 leads which is what I’m using. Can’t say I really know how they are wired but they certainly work with phones. I have simply taken a lead from each of my FXO ports into the patch panel.

what does (zap show channels) say in (asterisk -rvvv)?


Ok so then it need to be

RJ45 RJ11 TDM400


Ian[quote]I really know how they are wired but they certainly work with phones. I have simply taken a lead from each of my FXO ports into the patch panel.[/quote]

The problem may be that , BT phones and many other UK handsets use straight through lead and the line is on 2 and 5 of the RJ11, What phones are they ?

Here is the output from zap show channels

Chan Extension Context Language MOH Interpret
pseudo manual en default
3 manual en default
4 manual en default