No joint capabilities for 'audio' media stream

Good morning everyone,
After the extensions.conf and pjsip.conf files setup, I’m trying to make a call to the PBX from my mobile. The issue I’m having is about mismatching codecs. This is the error:

[Sep 11 08:13:56] NOTICE[2173955] res_pjsip_sdp_rtp.c: No joint capabilities for 'audio' media stream between our configuration((g722|ulaw|alaw)) and incoming SDP((g729))

This is my pjsip.conf file:

;================================ TRANSPORTS ==
; Our primary transport definition for UDP communication behind NAT.

[transport-udp-nat]
type = transport
protocol = udp
bind = 0.0.0.0
; NAT settings
;local_net = 10.0.0.0/8
;external_media_address = 203.0.113.1
;external_signaling_address = 203.0.113.1

;================================ CONFIG FOR SIP ITSP ==

[BBBELL-trunk]
type = registration
transport = transport-udp-nat
outbound_auth = BBBELL-trunk-auth
server_uri = sip:sip.local.bbbell:5060
client_uri = sip:<username>@sip.local.bbbell:5060
;client_uri = sip:0110162149@sip.local.bbbell:5060
outbound_proxy = sip:192.168.1.6\;lr
retry_interval = 60
line = yes
endpoint = BBBELL-endpoint

[BBBELL-trunk-auth]
type = auth
auth_type = userpass
username = <username>
password = <password>
realm = sip.local.bbbell

[BBBELL-endpoint]
type=endpoint
context = incoming
disallow = all
allow = !all,g722,ulaw,alaw
outbound_auth = BBBELL-auth
aors = BBBELL-aor
direct_media = no
from_domain = sip.local.bbbell
outbound_proxy = sip:192.168.1.6\;lr
[BBBELL-auth]
type = auth
auth_type = userpass
username = <username>
password = <password>
realm = sip.local.bbbell

[BBBELL-aor]
type = aor
contact = sip:sip.local.bbbell:5060
outbound_proxy = sip:192.168.1.6\;lr
qualify_frequency = 60

[BBBELL-identify]
type=identify
endpoint = BBBELL-endpoint
match = 192.168.1.6

;================================ ENDPOINT TEMPLATES ==
; Our primary endpoint template for internal desk phones.

[endpoint-internal](!)
type = endpoint
context = internal
;subscribecontext = incoming
;host = dynamic
disallow = all
allow = !all,g722,ulaw,alaw
direct_media = no
trust_id_outbound = yes
device_state_busy_at = 1
dtmf_mode = rfc4733

[auth-userpass](!)
type = auth
auth_type = userpass

[aor-single-reg](!)
type = aor
max_contacts = 1
;================================ ENDPOINT DEFINITIONS ==

;Roberta

[11](endpoint-internal)
auth = auth11
aors = 11
callerid = Roberta <11>

[auth11](auth-userpass)
password = sip11
username = 11

[11](aor-single-reg)
mailboxes = 11@example

The endpoint 11 is correctly registered to Asterisk and is Available.
This is the PJSIP trace:

[Sep 11 08:13:56] VERBOSE[2173954] res_pjsip_logger.c:
 <--- Received SIP request (803 bytes) from UDP:192.168.1.6:5060 --->
INVITE sip:0110162149@192.168.1.5:5060 SIP/2.0^M
Via: SIP/2.0/UDP 192.168.1.6:5060;branch=z9hG4bK530f97f61c8f4ffed^M
Max-Forwards: 70^M
From: 3357897423 <sip:3357897423@192.168.1.5:5060>;tag=ab5651555b^M
To: <sip:0110162149@192.168.1.5:5060>^M
Call-ID: 9cb685a403721c8c^M
CSeq: 6601 INVITE^M
Allow: ACK, BYE, CANCEL, INVITE, NOTIFY, OPTIONS, INFO, REFER, REGISTER^M
Contact: <sip:3357897423@192.168.1.6:5060;transport=udp>^M
Supported: replaces^M
User-Agent: Patton SN5200 4B EUI 00A0BA1004BE R6.9 2017-03-13 H323 SIP M5T SIP Stack/4.2.14.18^M
Content-Type: application/sdp^M
Content-Length: 216^M
^M
v=0^M
o=MxSIP 0 20 IN IP4 192.168.1.6^M
s=SIP Call^M
c=IN IP4 192.168.1.6^M
t=0 0^M
m=audio 4886 RTP/AVP 18 101^M
a=rtpmap:18 G729/8000^M
a=rtpmap:101 telephone-event/8000^M
a=fmtp:18 annexb=no^M
a=fmtp:101 0-16^M
a=sendrecv^M

[Sep 11 08:13:56] VERBOSE[2173955] pbx_variables.c: Setting global variable 'SIPDOMAIN' to '192.168.1.5'
[Sep 11 08:13:56] VERBOSE[2173955] res_pjsip_logger.c: <--- Transmitting SIP response (328 bytes) to UDP:192.168.1.6:5060 --->
SIP/2.0 100 Trying^M
Via: SIP/2.0/UDP 192.168.1.6:5060;rport=5060;received=192.168.1.6;branch=z9hG4bK530f97f61c8f4ffed^M
Call-ID: 9cb685a403721c8c^M
From: "3357897423" <sip:3357897423@192.168.1.5>;tag=ab5651555b^M
To: <sip:0110162149@192.168.1.5>^M
CSeq: 6601 INVITE^M
Server: Asterisk PBX certified/16.8-cert3^M
Content-Length:  0^M
^M

[Sep 11 08:13:56] VERBOSE[2173955] res_pjsip_logger.c: <--- Transmitting SIP response (382 bytes) to UDP:192.168.1.6:5060 --->
SIP/2.0 488 Not Acceptable Here^M
Via: SIP/2.0/UDP 192.168.1.6:5060;rport=5060;received=192.168.1.6;branch=z9hG4bK530f97f61c8f4ffed^M
Call-ID: 9cb685a403721c8c^M
From: "3357897423" <sip:3357897423@192.168.1.5>;tag=ab5651555b^M
To: <sip:0110162149@192.168.1.5>;tag=b34183fd-bdaf-4ce3-bc06-68508ae1a571^M
CSeq: 6601 INVITE^M
Server: Asterisk PBX certified/16.8-cert3^M
Content-Length:  0

I can’t force the SIP trunk to use a specific code even by specifying with additional lines to force the use of g722, ulaw or alaw.
I do not have any g729 codecs installed on my Asterisk, nor any license for the use of it, yet I don’t want to be forced to use that codec. g722 or ulaw would do equally good for this specific purpose.

Is there any way to solve this, since I’m unable to pick up any incoming call for now ?

Asterisk can not force an endpoint to use codecs it does not want, in this case the remote is only offering G729. You would need to change its configuration.