No Dahdi after Upgrade from 1.4.24 -> 1.4.25

I recently upgraded from 1.4.24 to 1.4.25 and while loading chan_dahdi I receive the follwing message:

lenny*CLI> module load
[May 26 22:03:21] WARNING[29104]: loader.c:400 load_dynamic_module: Error loading module '': /usr/lib/asterisk/modules/ undefined symbol: ast_smdi_interface_find
[May 26 22:03:21] WARNING[29104]: loader.c:640 load_resource: Module '' could not be loaded.

What can be the problem?

lenny*CLI> core show version
Asterisk 1.4.25 built by root @ lenny on a x86_64 running Linux on 2009-05-25 21:56:16 UTC

does dahdi_cfg -vv still work? If so, it’s probably just a compile error.

yes dahdi_cfg -vv still works…what can be wrong?

rerun make menuselect and deselect the smdi interface, then do
make && make install.

no this still does not work, result is the same :frowning:

do prior steps except unselect res_sdmi in 8. resource modules.

I upgraded now the dahdi to 2.2.x and tried asterisl 1.4.26.x, but still no sucess, and the same message when loading chan_dahdi…rolling back to Asterisk 1.4.24 and it works again

after much tinkering with format releases and candidate versions (8+ months), I am now on the SVN branch of 1.4. It seems to be much more stable and less error-prone (would say error-free, but that’s too much to ask for in a non-commercial, multi-platform product).