No Audio on Sip Bridging with Vonage

Hello,

I am experiencing no audio when I bridge two calls over my Vonage SIP Trunks. I can place calls outbound or inbound on these trunks. They sound great, better than my POTS at the office. But when I call into one of my numberd and try to bridge that to an outbound number it connects, but no audio.

I am running Asterisk 1.4.19.

Here is on of my sip trunks:
username=phone
type=friend
secret=password
port=5061
nat=yes
insecure=very
host=sphone1.vonage.net
fromuser=phone
fromdomain=sphone1.vonage.net
dtmfmode=rfc2833
disallow=all
defaultexpirey=120
canreinvite=no
auth=md5
allow=ulaw&alaw

Here is some CLI output:
AGI Script fixlocalprefix completed, returning 0
– Executing [s@macro-dialout-trunk:13] Set(“SIP/XXXXXXXXXXX-09810fb8”, “OUTNUM=6212600”) in new stack
– Executing [s@macro-dialout-trunk:14] Set(“SIP/XXXXXXXXXXX-09810fb8”, “custom=SIP/Vonage3”) in new stack
– Executing [s@macro-dialout-trunk:15] GotoIf(“SIP/XXXXXXXXXXX-09810fb8”, “0?gocall”) in new stack
– Executing [s@macro-dialout-trunk:16] Set(“SIP/XXXXXXXXXXX-09810fb8”, “DIAL_TRUNK_OPTIONS=M(setmusic^none)”) in new stack
– Executing [s@macro-dialout-trunk:17] Macro(“SIP/XXXXXXXXXXX-09810fb8”, “dialout-trunk-predial-hook|”) in new stack
[Apr 15 09:38:23] WARNING[20196]: app_macro.c:214 _macro_exec: Context ‘macro-dialout-trunk-predial-hook’ for macro ‘dialout-trunk-predial-hook’ lacks ‘s’ extension, priority 1
– Executing [s@macro-dialout-trunk:18] GotoIf(“SIP/XXXXXXXXXXX-09810fb8”, “0?bypass|1”) in new stack
– Executing [s@macro-dialout-trunk:19] GotoIf(“SIP/XXXXXXXXXXX-09810fb8”, “0?customtrunk”) in new stack
– Executing [s@macro-dialout-trunk:20] Dial(“SIP/XXXXXXXXXXX-09810fb8”, “SIP/Vonage3/6212600|300|M(setmusic^none)”) in new stack
[Apr 15 09:38:23] WARNING[20196]: rtp.c:1998 ast_rtp_settos: Unable to set TOS to 184
– Called Vonage3/6212600
– SIP/Vonage3-097f6cb0 is making progress passing it to SIP/XXXXXXXXXXX-09810fb8
– SIP/Vonage3-097f6cb0 answered SIP/XXXXXXXXXXX-09810fb8
– Executing [s@macro-setmusic:1] NoOp(“SIP/Vonage3-097f6cb0”, “Setting Outbound Route MoH To: none”) in new stack
– Executing [s@macro-setmusic:2] SetMusicOnHold(“SIP/Vonage3-097f6cb0”, “none”) in new stack
– Packet2Packet bridging SIP/XXXXXXXXXXX-09810fb8 and SIP/Vonage3-097f6cb0

Thank you,
nu1sg