No audio issue (rtp debug doesn't show activity during call)


I’m not sure if this is the right place to ask for help regarding our ongoing issue. I’ve tried posting on freePBX unfortunately we’re not getting any good response yet. That is why i’ve decided to post it here for your help.

We have just installed our FreePBX distro. All is set,(extensions, Trunk, Inbound/Outbound route, etc.) We can now also dial numbers and extensions thru softphone.
The problem was, there is problem with the audio as we can’t hear each other on both end.
We have tried using the rtp debug but it doesn’t show any activity once we’ve made a call.

Also we’re getting this warning once we’ve dialed extensions:
WARNING[23379][C-0000009f]: ccss.c:1000 ast_set_cc_callback_macro: Usage of cc_callback_macro is deprecated. Please use cc_callback_sub instead.

Please help.

Thanks in advance!


You need to stay in their forums since they are the mainteiners of the FreePBX code, your issue is a very common issue you need to use google to found the reason, my hint: fix your nat settings.

About the warning seems like you are using an old freepbx version try the latest. Also you can get help from the freenode’s IRC.