No audio heard in Hello World

I’ve just set up asterisk and zoiper and am trying the hello world sample. Zoiper connects to my asterisk ok and when I call extension 100 the call is accepted but I hear no audio. From another thread, I learned that asterisk was trying to pass the audio to my public IP and that I might try disabling STUN to use my local network address. As soon as I disable stun when I make a call the call is connected and ends immediately.

This is a call log with stun disabled:

== Setting global variable 'SIPDOMAIN' to '192.168.1.46'
    -- Executing [100@from-internal:1] Answer("PJSIP/6001-0000000f", "") in new stack
       > 0x74213c70 -- Strict RTP learning after remote address set to: 192.168.1.36:8000
       > 0x74213c70 -- Strict RTP switching to RTP target address 192.168.1.36:8000 as source
    -- Executing [100@from-internal:2] Wait("PJSIP/6001-0000000f", "1) same = n,Playback(hello-world") in new stack
    -- Executing [100@from-internal:3] Hangup("PJSIP/6001-0000000f", "") in new stack
  == Spawn extension (from-internal, 100, 3) exited non-zero on 'PJSIP/6001-0000000f'

This is the log for calls that went through but no audio, with stun enabled.

 == Setting global variable 'SIPDOMAIN' to '192.168.1.46'
    -- Executing [100@from-internal:1] Answer("PJSIP/6001-00000000", "") in new stack
       > 0x74214968 -- Strict RTP learning after remote address set to: 185.244.215.203:8000
       > 0x74214968 -- Strict RTP qualifying stream type: audio
       > 0x74214968 -- Strict RTP switching source address to 192.168.1.36:8000
    -- Executing [100@from-internal:2] Wait("PJSIP/6001-00000000", "1) same = n,Playback(hello-world") in new stack
    -- Executing [100@from-internal:3] Hangup("PJSIP/6001-00000000", "") in new stack
  == Spawn extension (from-internal, 100, 3) exited non-zero on 'PJSIP/6001-00000000'

Any help or suggestions is appreciated.

Asterisk is not trying to play any audio, due that you mistyped the line with the playback app

That was it. STUN off worked after I fixed the error. When I copied/pasted from the hello world page to create extensions.conf and pjsip.conf, the content pasted as one line and I had to restore the line feeds. I missed one and that was the cause.

Now all I need is a compatible softphone for a Raspberry Pi and I’m in business. Thanks.