No audio from outside network

I am able to connect calls from outside to outside my network but there isn’t any audio in those calls. I am almost certain that it has to do with my RTP ports. My port range is 8000 to 31000 on my firewall and rtp.conf. By setting “rtp set debug on”, I was able to see some packet information. Receiving packets from 35552 caught my attention. Based on the fact that I have port forwarding from 8000 to 31000, does anybody see anything that would point to having no audio?

Got RTP packet from 64.33.191.39:35552 (type 00, seq 006341, ts 4283766244, len 000160) Sent RTP packet to 10.2.0.143:8000 (type 00, seq 044109, ts 043680, len 000160) Got RTP packet from 10.2.0.143:8000 (type 00, seq 004722, ts 3923734768, len 000160) Got RTP packet from 64.33.191.39:35552 (type 00, seq 006342, ts 4283766404, len 000160) Sent RTP packet to 10.2.0.143:8000 (type 00, seq 044110, ts 043840, len 000160) Got RTP packet from 10.2.0.143:8000 (type 00, seq 004723, ts 3923734928, len 000160) Got RTP packet from 64.33.191.39:35552 (type 00, seq 006343, ts 4283766564, len 000160) Sent RTP packet to 10.2.0.143:8000 (type 00, seq 044111, ts 044000, len 000160) Got RTP packet from 10.2.0.143:8000 (type 00, seq 004724, ts 3923735088, len 000160) Got RTP packet from 64.33.191.39:35552 (type 00, seq 006344, ts 4283766724, len 000160) Sent RTP packet to 10.2.0.143:8000 (type 00, seq 044112, ts 044160, len 000160) Got RTP packet from 10.2.0.143:8000 (type 00, seq 004725, ts 3923735248, len 000160) Got RTP packet from 64.33.191.39:35552 (type 00, seq 006345, ts 4283766884, len 000160) Got RTP packet from 10.2.0.143:8000 (type 00, seq 004726, ts 3923735408, len 000160) Sent RTP packet to 10.2.0.143:8000 (type 00, seq 044113, ts 044320, len 000160)

rtp.conf

rtpstart=8000 rtpend=31000

10.2.0.143 is an internal address. Is there any reason why it should be sending packets to this address? If packets are passing through a nat-ed router, what are your nat settings in sip.conf?

Ian

Here is the basics of what my sip.conf layout is. As you can see I’m setting nat=yes. The local ip address you see is the computer that my softphone is running on.

[code][general]
;! register => tkcsam:R7quad@sip2sip.info/tkcsam
register => xxxx:xxxx@voip.baldwin-telecom.net/xxxx
context = unauthenticated ;default context for incoming calls
allowguest=yes ; disable unauthenticated calls
srvlookup=yes ;enabled dns srv record lookup on outbound calls
udpbindaddr=0.0.0.0 ;listen to udp requests on all interfaces
tcpenable=no ;disable tcp support
localnet=10.2.0.0/255.255.0.0
externip=68.65.34.156
bindaddr=0.0.0.0
nat=yes
qualify=yes

[bti]
type = friend
host = voip.baldwin-telecom.net
username = xxxxxx
secret = xxxxx
port=5060
bindaddr=0.0.0.0
insecure = invite
dtmfmode = rfc2833
domain=voip.baldwin-telecom.net
fromdomain=voip.baldwin-telecom.net
todomain=voip.baldwin-telecom.net
fromuser=xxxxx
;allowguest=yes
allow = ulaw
nat=yes
canreinvite=no

[/code]

Are there any packets being sent to the remote device? (There are none in the rtp debug output you posted.)

To keeps things simple, try just accessing Asterisk from the remote device - listening to/leaving a voicemail is good way to start. If the remote device can be configured to use a STUN server, try using it. Some routers try to do ‘clever’ things with voip traffic, but it’s usually not so clever. If you have something like that on your router, turn it off.

Finally, you should really set “allowguest=no” unless you have a good reason for needing it to be yes.

Ian

Why ???

Use wireshark to capture streams and capture on the ports , then revert back the rtp logs to voice , see if you get any voice on that test .

Thanks

Should nat=no?? My asterisk server is behind a router and firewall. I did use wireshark and it showed that my port range was extremely high. In the 50000 range even though in my rtp.conf I have it limited between 8000-10000

nat= describes the peer situation, not yours. nat=yes is one of the many incantations used by misinformed asterisk users.
You also use type=friend for no reason.
Not sure why you keep port 5060 open either …

I’ve just been going off tutorials from the O’Reilly Asterisk book so that’s what I have based my setup on. Can somebody show me an example of how they have theirs set up? I feel like I’m missing something