No application 'voicemail' for extension

working on setting up a voicemail.conf on my “first” pbx set up. i am getting the above error on my test setup. my voicemail.conf file looks like this;

1000 => 1000,1000,
1001 => 1001,1001,

and my ext conf looks like this;

exten => 1000,1,dial(sip/1000,10)
exten => 1000,n,voicemail(1000@default,u)
exten => 1000,n,hangup()

When i register the softphone the asterisk server also keeps telling me that a user with no mailbox has registered which is also incorrect. no idea what I’m doing wrong here. I have reloaded dialplan sip extensions and vm but still no good. I am also getting a busy signal when calling 1000 but when i use 1000 to call another extension it works fine?

any help is appreciated. Thank-you.

when you built it was the voicemail application built…
core show application voicemail wil show you if its built


this install was done by a tech at my provider due to the fact that they killled my other server so i don’t know if they followed the correct process. I asked the same question of them and they insist that it was installed properly but I’m guessing NOT. When i run core show application voicemail it fails and says the application is not registered.

I went back in and ran ./configure make and make install just to be sure and i still get the same error message.

you need to do “make menuselect”

then make sure voicemail is selected, then recompile.

I must be doing something wrong here. I have tried running “make menuselect” both as root in the webserver framework (using putty) and in Asterisk itself with no luck in either local. I get an error message saying no rule to create ‘menuselect’. I’m new to this and apologize but I have a rather steep learning curve. Thank-you for your help!

Thanx again. I found some further instructions on another site which cleared up the “menuselect” issue. Hopefully this corrects the voicemail issue. Thank-you again.