Newbie with a priority problem!

Trying to launch my first dial out to Teliax and getting this error

[May 29 03:08:06] WARNING[1955]: pbx.c:4644 add_pri: Unable to register extension ‘204’, priority 2 in ‘brad’, already in use

[general]
static=yes
writeprotect=no
clearglobalvars=no

[globals]
CONSOLE=Console/dsp ; Console interface for demo
IAXINFO=guest ; IAXtel username/password
TRUNK=Zap/g2 ; Trunk interface
TRUNKMSD=1 ; MSD digits to strip
(usually 1 or 0)

[default]
exten => 800xxxxxxx,1,Answer()
exten => 800xxxxxxx,2,Wait(1)
exten => 800xxxxxxx,3,Queue(service|t||8005181896|45)

exten => 800xxxxxxx,1,Answer()
exten => 800xxxxxxx,2,Wait(1)
exten => 800xxxxxxx,3,AgentLogin()

exten => h,1,DeadAGI(postqueue.agi)

[brad]
exten => 204,1,Wait()
exten => 204,2,Answer
exten => 204,3,Playback(demo-congrats)
exten => 204,4,Hangup
exten => 204,2,Dial(Zap/g2,20)
;exten => 204,Voivemail(u100)

Still not working! Grrr!

[204]
exten => 204,1,Wait()
exten => 204,2,Answer
exten => 204,3,Playback(demo-congrats)
exten => 204,4,Hangup

exten => s,1,Dial,(Zap/g2)
exten => s,2,Hangup
;exten => 204,Voivemail(u100)

Did you reload asterisk after making the change?

p.s. this is why it’s a good idea to use ‘n’ instead of explicitly numbering your rules.

Debug says SIP/2.0 401 Unauthorized

Here is my basic question which is not answered directly “big bird-cookie monster” style in any of the literature.

Sip.conf is your basic authentication file which the CLI: show sip peers tells you if you are correct. I got that much.

Now, do you have to declare that again anywhere in extensions.conf or do you simply call on your trunked globals?

If this is the case: SIP/[@][:] Hence exten => 204,2,Dial(Zap/g2,20)

shoulds work just fine???

Yes, always reloading!

Got a hair trigger on the reload button!

Capabilities: us - 0x40e (gsm|ulaw|alaw|ilbc), peer - audio=0x4060e (gsm|ulaw|alaw|speex|ilbc|h261)/video=0x40000 (h261), combined - 0x40e (gsm|ulaw|alaw|ilbc)
Non-codec capabilities (dtmf): us - 0x1 (telephone-event), peer - 0x1 (telephone-event), combined - 0x1 (telephone-event)
Peer audio RTP is at port 66.176.193.46:5016
Looking for 9158332042 in home (domain 66.109.17.92)

<— Reliably Transmitting (no NAT) to 66.176.193.46:5081 —>
SIP/2.0 404 Not Found
Via: SIP/2.0/UDP 66.176.193.46:5081;branch=z9hG4bKc91e2033-ccf8-1810-9367-0013d3ee21fe;received=66.176.193.46;rport=5081
From: “Brad S” sip:204@66.109.17.92;tag=44002033-ccf8-1810-9363-0013d3ee21fe
To: sip:9158332042@66.109.17.92;tag=as06d3acaa
Call-ID: 2afa1f33-ccf8-1810-9363-0013d3ee21fe@usmc
CSeq: 2 INVITE
User-Agent: Asterisk PBX
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces
Content-Length: 0

<------------>
Scheduling destruction of SIP dialog ‘2afa1f33-ccf8-1810-9363-0013d3ee21fe@usmc’ in 32000 ms (Method: INVITE)

<— SIP read from 66.176.193.46:5081 —>
ACK sip:9158332042@66.109.17.92 SIP/2.0
CSeq: 2 ACK
Via: SIP/2.0/UDP 66.176.193.46:5081;branch=z9hG4bKc91e2033-ccf8-1810-9367-0013d3ee21fe;rport
From: “Brad S” sip:204@66.109.17.92;tag=44002033-ccf8-1810-9363-0013d3ee21fe
Call-ID: 2afa1f33-ccf8-1810-9363-0013d3ee21fe@usmc
To: sip:9158332042@66.109.17.92;tag=as06d3acaa
Proxy-Authorization: Digest username=“204”, realm=“asterisk”, nonce=“1a3db830”, uri="sip:9158332042@66.109.17.92", algorithm=md5, response="cb7cedabcc0b4c20d2b948d05f67218c"
Allow: INVITE,ACK,OPTIONS,BYE,CANCEL,NOTIFY,REFER,MESSAGE
Content-Length: 0
Max-Forwards: 70

I have address that issue.
I seem to be getting a “unknown user” error from teliax.
Apparently, I am not sending the call through my authenticated trunk in sip.conf?

Suggestions anyone?