Newbie question: Unable to specify channel 1: No such device


#1

I sorry to bother you guys here, but I searched and searched, but can’t find any thing like that.

I had a Wildcard TDM400P card with 1 FXO module on the forth port.
I am use Suse 9.1 (linx26) with Zaptel and Asterisk 1.2 beta
so I use make linux26 on zaptel build and changed my /etc/udev/udev.permissions and /etc/udev/rules accordingly
(voip-info.org/tiki-index.php … stallation)

I did
modprobe zatel
modprobe wctdm

checked /var/log/messages, looks like everthing is OK
and the green led lighted up on the forth port of the card

Here is my zaptel.conf

fxsks=1
loadzone = us
defaultzone=us

then I run ztcfg -vvvvv

it shows
Zaptel Configuration

Channel map:

Channel 01: FXS Kewlstart (Default) (Slaves: 01)

1 channels configured.

And here is my /etc/asterisk/zapata.conf
[channels]
language=en
context=default
switchtype=national
signalling=fxs_ks
channel => 1

then I ran asterisk with asterisk -vvvvvvvc
And it errored out:
chan_zap.so] => (Zapata Telephony)
== Parsing ‘/etc/asterisk/zapata.conf’: Found
’/dev/zap/channel’:
Sep 10 22:17:55 WARNING[12059]: chan_zap.c:892 zt_open: Unable to specify channel 1: No such device
Sep 10 22:17:55 ERROR[12059]: chan_zap.c:6652 mkintf: Unable to open channel 1: No such device
here = 0, tmp->channel = 1, channel = 1
Sep 10 22:17:55 ERROR[12059]: chan_zap.c:10032 setup_zap: Unable to register channel '1’
Sep 10 22:17:55 WARNING[12059]: loader.c:403 __load_resource: chan_zap.so: load_module failed, returning -1
Sep 10 22:17:55 WARNING[12059]: loader.c:543 load_modules: Loading module chan_zap.so failed!

I looked at the source code, it looks like it passed line 880 open(fn, O_RDWR | O_NONBLOCK); so the device opened correctly, but failed at
ioctl(fd, ZT_SPECIFY, &chan)

could you guys tell me what I did wrong?

I tried that on two machines, All the same problem. Now I am stuck.

Any suggestion will be appreciated


#2

Read the README in the zaptel driver source code directory.

Of course I heop you ade the zaptel driver using
make linux26

Also,
This mght be a udev issues.

In which case, I hade to create the .permission and .rules file in the /etc/udevs.d/ directory tree. This is simpel to do and seems to work.
What is happening is that as the module is inserted, it doesn’t know how to create the devices in the /dev file tree. You have to tell it how to.

The README is great to copy exact.

Next, even with a perfect zaptel.conf file I still have to modprobe wctdm twice to get it to work. In my system startup file I

wtcfg -vvv
modprobe wctdm

sleep 2

modprobe wctdm

Why, I don’t know, but based on other posting, I am not the only one.
The first modprobe errors most of the time.

Now, most things work except I can not detect when a call is answered by an external user using the TDM400. Is this related, incoming calls are OK.

Hmm another topic


#3

Ignore the first part of my response - I replied to wrong post.

Try modprobe twice - seems to fix my issue


#4

modprobe wctdm twice doesn’t work

cat /proc/interrupts shows :

7: 938120 XT-PIC wctdm

So it looks ok and the card is not sharing interrupts with others.

Most posts here had problems when the ztcfg failed, but in my case ztcfg succeeded. When I trace the code, even the open call in the zt_open() went through. It is the ioctl call failed. Which falles back in the zaptel’s zaptel.c line 2179, function zt_specchan_open
if (chans[unit] && chans[unit]->sig)
this condition failed and returned ENXIO, which cause the console to print out “No such device”. I don’t know if I can insert some prints there to check what unit and chans[unit]->sig is.

Could some of my configure file cause that or it might be a hardware problem? (In case I accidentally zapped the card?) My machine is Dell PowerEdge 500sc. It is not in the incompatable list of Dignium. And I tried the card on another home build machine. It gives the same error as well. So less likely to be a incompatible problem.

Thanks


#5

you might want to look here

voip-info.org/tiki-index.php … aptel.conf

do you have fxs or fxo on ports 1-3 if not I believe I would move the moduel from port 4 to 1 to make life easier or else I think you would need

fxsks=4

channel = 4


#6

Thanks a lot!

That’s it. fxsks=4 and channel=4.

I thought those number’s are logical number.
But seems like they are phical locations where the fxs/fxo modules are located in the tdm card