Need to type a question mark in CLI [ANSWERED]

Hi Folks,
in order to debug a problem with my voismart VGSM cards I need to type a question mark into the command line so i can issue the correct AT command to the GSM modules via a “rawcommand” option provided by the VGSM channel driver.

It seems the CLI is eating my ? character, is there a way of escaping it or something?
I’m on asterisk

Also I really tried to search the forums for this but the forum search form also auto omits the word “question” from my search terms… have digium got something against the humble interrogative? :smile:


Where do you want to enter the command ? Do you want to run it in asterisk CLI or in DialPlan via system application ?

If you want to run from CLI you can use asterisk -rx " and then your command " in linux CLI
If you want to run from Dialplan then why dont you write your command in bash script and pass it to system application ?

Thanks Omid,
invoking asterisk with the -rx option worked nicely, that’s a useful tip.