Need help installing asterisk from source

I have A Machine running centos 6 (Before someone comes out and tells me to put the digium and asterisk repository server url in the system to install asterisk from the repository, I have already did that but I want to install the latest version which is available from souce, if not then I believe that this will solve potential problems when I plan to install other programs). I ran the configure script on the asterisk source code successfully but when i run the make command I get this response

make: Warning: File `Makefile' has modification time 2.6e+08 s in the future
**** The configure script must be executed before running 'make'.
****               Please run "./configure".
make: *** [makeopts] Error 1

Obviously I have ran the configure script before trying the make command but I don’t see what the problem here is, This has worked on other installations in centos 6 but this machine isn’t making things easier and I want to know why it’s giving me this error and how I can make it stop. Since I read that it was a time thing I connected it to an NTP server to get it’s updates from, allowed it’s time to synchronize and ran the configure and make commands again and still get that error. I want to know what is going on here and how I can get rid of this error. is there a setting that I can turn off to make it stop comparing times with the makefiles?

If your server time was way off when you extracted the source tree, then all of your file and directory dates are going to to be really confused. Delete the directory, make sure that your server time is close to right, then re-extract the asterisk.tar.gz file.

I just setted to the NTP server and rebooted (something I neglected to do a long time ago but RedHat distributions have been known to require a lot of reboots, sometimes I wonder why corporations prefer to use it as opposed to Debian based distributions). IAX2 phones might be a problem I just started to try setting up the dialplans but that is a problem for another thread.


No need. ntpdate -u your.ntp.server.tld