managerAMI not connecting:Connection cloased by foregin host

I am going through the asterisk definite guide and I followed the manager guide
This is my manager.conf file.
I am using Asterisk-1.8

; Asterisk Call Management support

; By default asterisk will listen on localhost only.
enabled = yes
webenabled = yes
port = 5038
bindaddr =


; No access is allowed by default.
; To set a password, create a file in /etc/asterisk/manager.d
; use creative permission games to allow other serivces to create their own
; files
#include “manager.d/*.conf” [/code]

After using sudo telnet 5038
and providing action,username,secret I am getting the following output

Connected to localhost.
Escape character is ‘^]’.
Asterisk Call Manager/1.1
Connection closed by foreign host.

I searched in the forum but nothing worked.

Did the forums not tell you that logging is essential to any debugging?

Sorry,I cant get you.Logging?

This is my log file

[Jun 7 22:55:44] VERBOSE[5328] config.c: == Parsing '/etc/asterisk/logger.conf': [Jun 7 22:55:44] DEBUG[5328] config.c: Parsing /etc/asterisk/logger.conf [Jun 7 22:55:44] VERBOSE[5328] config.c: == Found [Jun 7 22:55:44] VERBOSE[5328] logger.c: Asterisk Queue Logger restarted [Jun 7 22:56:40] VERBOSE[5533] manager.c: == Client from, failed to authenticate in 30 seconds [Jun 7 22:56:40] VERBOSE[5533] manager.c: == Connect attempt from '' unable to authenticate

Sorry for the inconvenience.

Did you include the bank line at the end of the request?

After adding blank line
It worked
thanks a lot :smile: