Manager API Originate error in Asterisk 1.6 Beta 8

This was working fine under the same configuration in Asterisk 1.4.17:

Action: Login
Username: xxxx
Secret: yyyy

Response: Success
Message: Authentication accepted

Action: Originate
Channel: SIP/15555551212@
Context: voiceSystemTest
Priority: 1

Response: Error
Message: Permission denied

Any idea why originate is broken in this version?

silly question.
did you confirm you have rights to make the call?

I am having the same problem, it was working fine with the same configuration under 1.4 now i upgraded to 1.6 and having the permission problem, my user has read and write permissions for “call” does it need any other extra permission (Starting from v 1.6) in order to originate calls?

Anyone solved this problem yet?


Manager has changed, It cannot be assumed that just because it worked in 1.4 that it will work in 1.6.

The release notes for manager 1.1 are here … iew=markup


Thanks for the link Ian.

I had to add “originate” and “system” permissions for the user which fixed the problem.