Make Asterisk use RTP even when SRTP is requested

OK Here we go…

We have over 65 phones that are connected to our hosted server at a colocation. The sip connections/phones are at remote locations all over the country. So, with that being said here is the problem.

We upgraded from Raw Asterisk 11.6 to 11.9. Our phones will not dial out now. I tested one of the phones and I set the RTP Encryption to “off” in the phone’s web interface and then the phone would dial out. I also reverted back to 11.6 and all the phones worked great.

I would like to upgrade to 11.9 because of patches and updates and this is always a good idea when you have a server sitting on the public internet.

It seems that in 11.6 that asterisk would not accept RTP Encryption even if it was asked and asterisk would just use RTP.

Does anyone know how to make 11.9 revert to RTP even if asked to use SRTP??

Here is the message I get: WARNING[1155][C-0000001e]: chan_sip.c:10543 process_sdp: We are requesting SRTP for audio, but they responded without it!

Many Thanks!!!

-John

I solved this problem by adding the following to modules.conf

noload=res_srtp.so

Thats it!!! Done