Junghanns 4bri + Asterisk 1.4

Hello People,

I have Asterisk installed with a Jungshanns 4bri card.
The cards installs fine and dialing in & out works.
But after a couple of days users are suddenly not able to dial out via the ISDN line.

The log gives;

Unable to create channel of type ‘ZAP’ (cause 34 - Circuit/channel congestion)

When I do a simple ‘reload’ on the Asterisk console users are able to dial out again.
I’ve tried all kinds of BRI-Stuff & Asterisk versions but nothing helped.

Anyone familiar with these symptoms???

The ISDN provider is KPN in The Netherlands
Here’s my zaptel.conf & zapata.conf


qozap span definitions

most of the values should be bogus because we are not really zaptel



; Default language
; Default context

switchtype = euroisdn

signalling = bri_cpe_ptmp

pridialplan = local
prilocaldialplan = dynamic
nationalprefix = 0
internationalprefix = 00

priindication = passthrough


group = 1
; S/T port 1
channel => 1-2

Help is very much appreciated.

Best Regards

Hendrik van der Ploeg
The Netherlands[/b]

Does core show channels
or the zaptel/dahdi show channels command indicate unexpected busy channels, and, if so, what is the status of such a channel and what is it bridged to?

unfortunatly I don’t know the answer when I do a ‘core show channel’.
The problem is that I cannot ‘force’ the problem to occur.
Is just suddenly happens



This is with a working phonecall to a Cell phone

*CLI> core show channels
Channel Location State Application(Data)
Zap/1-1 (None) Up Bridged Call(SIP/2701-081f6cd0
SIP/2701-081f6cd0 6021@volledig:1 Up Dial(ZAP/g1/cellphone#||T)
2 active channels
1 active call


This isn’t going to help, but… I saw the same behaviour of a Junghanns quadBRI under Asterisk 1.4. I didn’t get any help from Junghanns and my customer finally changed card.

But I have another customer who has been running a Junghanns BRI card happily for almost 18 months.

Not much help, I know. Sorry.


Yes, I also asked for help on the Junghanns website but didn’t received a reply.
Very bad!!!

Though lucky enough I found out that the mISDN module drivers also work on the junghanns card. http://www.misdn.org

Got it up and running and it’s now running for 5 days without problems.
I’ll keep you guys informed about the stability with mISDN.

I at least have a good experience with mISDN + AVM isdn cards.


Linux admin
The Netherlands

Hello guys,

Well, the ISDN line is running for 10 straight days now without a ‘reload’ on the Asterisk console.
So this problem has been solved.
Still a bit weird that the zapata driver provided by junghanns is not working all to well.


Linux Admin
The Netherlands

I always use mISDN for BRI - and leave Zaptel to the PRI and analogue trunks.

In fact, the Zaptel source directory includes a script that downloads and installs the mISDN drivers for you (make b410p)!.

Me too.


Marco Bruni