Joinempty = inuse not working

Hi guys, I have a problem with my Asterisk configuration.

The version of Asterisk is: 13.18
The operating system is: Debian 9

I configured a queue with two members and everything works normally.

But I would like that when all members of the queue are busy, new callers cannot enter the queue.

To achieve this I added the following option to the queue in the queues.conf: joinempty = inuse (I followed the explanation of the sample file: https://github.com/asterisk/asterisk/blob/master/configs/samples/queues .conf.sample)

The joinempty parameter, however, does not work, because the callers enter the queue even if all the members are busy (as if there is a member available).

Here is my queues.conf file (the queue is “q666”, I left only one member to make it easier to do tests with all busy members.):

[general]
persistentmembers = yes
autofill = no
shared_lastcall = yes

...other queues...

[q666]
announce-frequency = 0
announce-holdtime = no
announce-round-seconds = 10
autofill = yes
autopause = no
joinempty = inuse
leavewhenempty = yes
maxlen = 0
memberdelay = 0
periodic-announce-frequency = 0
reportholdtime = no
retry = 5
ringinuse = no
servicelevel = 0
strategy = ringall
timeout = 30
timeoutrestart = no
weight = 0
wrapuptime = 0
musicclass = default
;---- Members ----
member => SIP/2et11,1,fga

I tried to follow the solution proposed in this topic (add busy to joinempty) but it didn’t work in my configuration: Joinempty for inuse attendees

If I left out some important details in explaining my problem, I apologize, this is my first post on the forum. I am available to provide every detail.

Thank you in advance for your help.

I just tried this using the latest 13 branch, and it seems to work fine for me. 13.18 is a few versions old. I’d recommend upgrading to the latest released version. It’s possible a bug was fixed.

While it probably shouldn’t matter for this scenario I was using pjsip channels vs chan_sip.

If it’s still a problem after trying with the most recent version please post the output of the following before the call, and after:

*CLI> queue show q666

First of all, thank you for your help and your response.

Unfortunately I can’t update the Asterisk version due to the rules and dynamics of the company I work for.

In the end I solved using a mix of AGI (Python) and AMI (the company I work for has a software built on Asterisk that allows you to do this type of work before deciding which queue to send the caller to).

I am not at all convinced that it is the best solution but it works.

In the past I have used the “joinempty = inuse” parameter on other versions of Asterisk, probably more recent, and it has always worked without problems (I seem to remember that it worked but I’m not sure, unfortunately I don’t remember what Asterisk machines are where I used the parameter otherwise I was going to check now).

I believe my problem, as you said too, is due to a bug in this particular version in use on my PBX.

Thanks again for the help, I wish you a good day.