IVR Issue - Popping/clicking between sounds - Short RTP packets

I am putting together a new IVR platform and seeing some problems that I have not seen with Asterisk previously in this scenario. The IVR strings together multiple sounds using Background(). All sounds being played are slinear (although we have tried ULAW as well). Codec is ULAW with 20ms packetization throughout from multiple carriers inbound.

I am seeing this with my custom sounds and when stringing together built-in core sounds. I am hearing popping and clicking between the sounds on the remote end. Playing the RTP from a local packet capture does not produce audible issues. An anomaly I can see in the RTP capture is short packets when the popping/clicking occurs. One of these “short” packets for example has a length of 102 instead of 216 and the timestamp increment is less than 160.

It appears that these “short” RTP packets manifest in remote end-points and/or third-party remote carriers filling in the gap(s) with noise.

Any suggestions, tips or pointers would be greatly appreciated to move past this issue. I have been able to reproduce it on versions in the 20, 18, 16 and 13 chains. Main work is being done on 20.0.3.

Jason Park

@nrjchnd I see your post from last year “RTP Timestamp issue causes clicks & pops”. It sounds very, very similar to what we are experiencing. Di you have any success in solving for it?

Jason Park

does not sound solved

The reporter gave up on it before it was accepted, although, in my view they had proved their case by providing a detailed diagnosis and it didn’t need more details of the symptoms. It will need re-raising on Github, now.

Thanks for the info. I will re-raise in the new system.

Jason Park

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.