Issues Compiling Asterisk-Addons-1.4.4


I’m trying to compile asterisk on a CentOS 5 machine. All the previous compiles have worked (libpri, zaptel, asterisk, sounds)
The only thing that has not worked so far is Asterisk-Addons-1.4.4
My initial research has shown this is possibly a bug, but there is very little empirical data out there.
The stop error occurs on “make install.” /configure and make seem to run successfully.

[root@typhon asterisk-addons-1.4.4]# make install make[1]: Entering directory `/usr/src/asterisk/asterisk-addons-1.4.4' gcc -g -c -fPIC -fPIC -o app_saycountpl.o app_saycountpl.c gcc -shared -Xlinker -x -o app_saycountpl.o make[2]: Entering directory `/usr/src/asterisk/asterisk-addons-1.4.4/asterisk-ooh323c' make all-am make[3]: Entering directory `/usr/src/asterisk/asterisk-addons-1.4.4/asterisk-ooh323c' make[3]: Nothing to be done for `all-am'. make[3]: Leaving directory `/usr/src/asterisk/asterisk-addons-1.4.4/asterisk-ooh323c' make[2]: Leaving directory `/usr/src/asterisk/asterisk-addons-1.4.4/asterisk-ooh323c' make[2]: Entering directory `/usr/src/asterisk/asterisk-addons-1.4.4/format_mp3' make[2]: Nothing to be done for `all'. make[2]: Leaving directory `/usr/src/asterisk/asterisk-addons-1.4.4/format_mp3' make[1]: Leaving directory `/usr/src/asterisk/asterisk-addons-1.4.4' for x in; do /usr/bin/install -c -m 755 $x /usr/lib/asterisk/modules ; done make[1]: Entering directory `/usr/src/asterisk/asterisk-addons-1.4.4/format_mp3' /usr/bin/install -c -m 755 /usr/lib/asterisk/modules make[1]: Leaving directory `/usr/src/asterisk/asterisk-addons-1.4.4/format_mp3' make[1]: Entering directory `/usr/src/asterisk/asterisk-addons-1.4.4/asterisk-ooh323c' cp .libs/ /usr/lib/asterisk/modules/ cp: cannot stat `.libs/': No such file or directory make[1]: *** [install] Error 1 make[1]: Leaving directory `/usr/src/asterisk/asterisk-addons-1.4.4/asterisk-ooh323c' make: *** [install] Error 2

Any ideas? I’m not sure if i should try to resolve this now, before continuing on with my asterisk install, or if I should continue on, and resolve problem later.


Have a close look the answer is there. Here is the work-a-round.

asterisk addons;
make install
cp asterisk-ooh323c/.libs/libchan_h323.1.0.1 asterisk-ooh323c/.libs/
make install


That worked great.
I looked again. I think i see the problem but i’m not sure. I’m still not that good at reading compile time errors.

It would appear that “make” is not creating the appropriate links for this error: `/usr/src/asterisk/asterisk-addons-1.4.4/asterisk-ooh323c' cp .libs/ /usr/lib/asterisk/modules/