Issues after upgrading from 15.2.1 to 15.2.2/15.3.0


I run a well functioning Asterisk server in version 15.2.1 with pjsip for SIP over all transports (UDP, TCP, TLS, WebSocket). I use it with a WebRTC WebPhone (based on SIP.js) as well as classic SIP clients and phones.

After a test upgrade to Asterisk 15.2.2 and 15.3.0 (both tested, same result) I have the following problems:

  • I can not hear any sound (not even a ringing tone, no playback in ConfBridge)
  • If the other party accepts the call, the call ends after one second

I found the following:

  • After canceling the call, the following appears in the log:
  == Everyone is busy/congested at this time (1:0/0/1)
    -- Executing [0123456789@sipuser-sipprovider-out:3] Hangup("PJSIP/asteriskaccount-00000002", "") in new stack
  • In comparison with version 15.2.1 the following is missing in the log of a call:
       > 0x7fd59c039190 -- Strict RTP learning after remote address set to:

Does anyone have any idea what the problem may be?

Here’s the log of the call: = Asterisk server / = My PC (external/internal)
345.345.345.345 / = SIP provider

You need to look further back in the logs and/or turn up the logging level to find out why Asterisk is reporting channel unavailable.

Although I’ve never tried WebRTC, the general view is that you should not attempt it unless you are already sufficiently familiar with SIP and other relevant protocols that you would have already provided a lot more detail about the problem.

WebRTC is not the issue here, it works perfectly with Asterisk 15.2.1. When upgrading to 15.2.2/15.3.0 the problem occurs with ALL protocols and with ALL clients (web phone, software phone, hardware phone). Something must have be changed by Asterisk.

I had active:
core set debug 9
core set verbose 9
pjsip set logger on
rtp set debug on

And the linked log contains as reason:

Reason: Q.850;cause=58

58 is “Bearer Capability Not Available”

That might well be a codec mismatch, but I’d rally need to see the INVITE and final response, in full.

I have linked the complete log in the first post from the beginning. Have not you seen it?

The problem has resolved itself with an upgrade of the operating system. Maybe a wrong library or something like that. It’s now working with 15.3.0.