Is it OK to ignore these messages

In the process of cross compiling asterisk versions from 1.4 to 1.8 I encountred this message in the last task of this process “linking all .o object file to produce this asterisk”. So tried to search for a solution but ? I don’t know “may I rewrite the source file of utils.c and replace gethostbyname_r by getnameinfo ?” or I must play wih -lresolv option in the makefiles out there. So I tried this move:

when the these message shows up:

[LD] abstract_jb.o acl.o adsi.o alaw.o aoc.o app.o ast_expr2.o ast_expr2f.o asterisk.o astfd.o astmm.o astobj2.o audiohook.o autochan.o autoservice.o bridging.o callerid.o ccss.o cdr.o cel.o channel.o chanvars.o cli.o config.o data.o datastore.o db.o devicestate.o dial.o dns.o dnsmgr.o dsp.o enum.o event.o features.o file.o fixedjitterbuf.o frame.o framehook.o fskmodem.o global_datastores.o hashtab.o heap.o http.o image.o indications.o io.o jitterbuf.o loader.o lock.o logger.o manager.o md5.o netsock.o netsock2.o pbx.o plc.o poll.o privacy.o rtp_engine.o say.o sched.o security_events.o sha1.o slinfactory.o srv.o ssl.o stdtime/localtime.o strcompat.o strings.o stun.o syslog.o taskprocessor.o tcptls.o tdd.o term.o test.o threadstorage.o timing.o translate.o udptl.o ulaw.o utils.o version.o xml.o xmldoc.o editline/libedit.a db1-ast/libdb1.a -> asterisk /opt/or1k-toolchain/lib/gcc/or1k-linux-uclibc/4.9.0/../../../../or1k-linux-uclibc/bin/ld: cannot find -lresolv utils.o: In function `ast_gethostbyname': /home/mohessaid/asterisk- warning: gethostbyname_r is obsolescent, use getnameinfo() instead. collect2: error: ld returned 1 exit status make[1]: *** [asterisk] Error 1 make: *** [main] Error 2

I used make -i to avoid this error and the process complete but I think something is missing when I write :

you can see this line in the messages printed by the installation script:

/usr/bin/install -c -m 755 main/asterisk "/home/mohessaid/asterisk/usr/sbin/" /usr/bin/install: cannot stat `main/asterisk': No such file or directory make: [bininstall] Error 1 (ignored)

so how can I solve this problem please?

NS: the installation complete with success.


make[1]: *** [asterisk] Error 1

indicates a fatal error.

So, what is the solutions david, rewriting the code?

Use a supported platform or debug the build system.