Intermittent One-Way Audio on Incoming Calls

Hi there,

our one way audio problem is there again :frowning:
After I ruled out all codec mismatches and got our ISDN PABX (Auerswald Compact) talking perfectly with Asterisk on SIP level, we now encountered similar trouble with the Sipgate Trunk. Outbound calls always work perfectly, but inbound only to 50% or less. In these cases, the calling party cannot be heard, while everything spoken into a local SIP phone (Snom 320s and a few Gigasets) is perfectly reproduced at the callers side.
I would accept NAT problems as the only reason if it were a permanent problem, but it is as intermittent as it can be.
After some tweaking I called in 8-9 times without problems but then it reappeared. It does not matter how long I wait between calls (assuming there’s still an UDP port open on the router) or whether another peer is in use at this moment.
Our router is a Draytek Vigor 2820, it makes no difference whether I forward 49152-49408 (the ports defined in rtp.conf) to the * or not. We’re going to swap the router for a Cisco on wednesday if no other solution comes to help.


Please record the network traffic to see what is happening to the RTP packets.

I have just fixed a problem like this that took two weeks on grinding to get to the bottom of it including complete deep packet analysis. We found that everything was fine in terms of packet flow BUT a cisco appliance was inspecting packets and deciding that the RTP packets were “mal formed” and passing them through empty of content. After discussion with Cisco engineers, they indicated that packet inspection on their devices do in fact intermittently wll do that and recommended that we turn off packet inspection for RDP. We did that and the systems have been rock solid ever since.

@ mudslide567:
what was the cisco device you had and do you recall the command to disable RDP packet inspection? I’m having one-way-audio problems and using a cisco device too, I can’t find where/how to do this. thanks for any advice.