Install Asterisk 1.4.2 on a OpenSuse 10.3 64bit ERRORS-Help!

Hi all…
I am trying to install Asterisk 1.4.2 on a OpenSuse 10.3 64bit.
The ./configure passes OK.
:smile: Yet when I run the make, I get errors as it follows below.
Anyone may suggest anything?
Many thanks in advance!

make[1]: Entering directory /iskoot-install/asterisk/asterisk-1.4.2/menuselect' make[2]: Entering directory/iskoot-install/asterisk/asterisk-1.4.2/menuselect’
make[3]: Entering directory /iskoot-install/asterisk/asterisk-1.4.2/menuselect/mxml' cc -O -Wall -c mxml-attr.c cc -O -Wall -c mxml-entity.c cc -O -Wall -c mxml-file.c cc -O -Wall -c mxml-index.c cc -O -Wall -c mxml-node.c cc -O -Wall -c mxml-search.c cc -O -Wall -c mxml-set.c cc -O -Wall -c mxml-private.c cc -O -Wall -c mxml-string.c /bin/rm -f libmxml.a /usr/bin/ar crvs libmxml.a mxml-attr.o mxml-entity.o mxml-file.o mxml-index.o mxml-node.o mxml-search.o mxml-set.o mxml-private.o mxml-string.o a - mxml-attr.o a - mxml-entity.o a - mxml-file.o a - mxml-index.o a - mxml-node.o a - mxml-search.o a - mxml-set.o a - mxml-private.o a - mxml-string.o ranlib libmxml.a make[3]: Leaving directory/iskoot-install/asterisk/asterisk-1.4.2/menuselect/mxml’
cc -Wall -o menuselect.o -g -c -D_GNU_SOURCE menuselect.c
cc -Wall -o menuselect_curses.o -g -c -D_GNU_SOURCE menuselect_curses.c
cc -Wall -o strcompat.o -g -c -D_GNU_SOURCE strcompat.c
cc -g -Wall -o menuselect menuselect.o menuselect_curses.o strcompat.o mxml/libmxml.a -lncurses
make[2]: Leaving directory /iskoot-install/asterisk/asterisk-1.4.2/menuselect' make[1]: Leaving directory/iskoot-install/asterisk/asterisk-1.4.2/menuselect’
menuselect/menuselect --check-deps menuselect.makeopts

The existing menuselect.makeopts file did not specify
that ‘chan_phone’ should not be included. However, either some
dependencies for this module were not found or a
conflict exists.

Either run ‘make menuselect’ or remove the existing
menuselect.makeopts file to resolve this issue.

make: *** [menuselect.makeopts] Error 255


You should run “make menuselect” before run “make” and choose not to build chan_phone; seems you’re using the 1.4.2 version, I think you should try a newer version, last is 1.4.21.


Marco Bruni

Many thanks for your suggestion.
Someone else suggested to erase menuselect.makeopts file and run make again.
It worked all the way.
Not sure what was the difference between your suggestion and what I did and that may affect further the way Asterisk functions.