Incoming calls on EM_W ( wink start) T1


#1

When calling in the line picks up , but asterisk kicks the call out, here is the excerpt of the log:
May 2 13:22:23 VERBOSE[4223] logger.c: – Starting simple switch on 'Zap/3-1’
May 2 13:22:23 DEBUG[4223] chan_zap.c: DTMF digit: * on Zap/3-1
May 2 13:22:23 DEBUG[4223] chan_zap.c: DTMF digit: * on Zap/3-1
May 2 13:22:23 DEBUG[4223] chan_zap.c: DTMF digit: 6 on Zap/3-1
May 2 13:22:23 DEBUG[4223] chan_zap.c: DTMF digit: 5 on Zap/3-1
May 2 13:22:23 DEBUG[4223] chan_zap.c: DTMF digit: 4 on Zap/3-1
May 2 13:22:24 DEBUG[4223] chan_zap.c: DTMF digit: 3 on Zap/3-1
May 2 13:22:24 DEBUG[4223] chan_zap.c: DTMF digit: 4 on Zap/3-1
May 2 13:22:24 DEBUG[4223] chan_zap.c: DTMF digit: 0 on Zap/3-1
May 2 13:22:24 DEBUG[4223] chan_zap.c: DTMF digit: 1 on Zap/3-1
May 2 13:22:24 DEBUG[4223] chan_zap.c: DTMF digit: * on Zap/3-1
May 2 13:22:24 DEBUG[4223] chan_zap.c: Enabled echo cancellation on channel 3
May 2 13:22:24 VERBOSE[4223] logger.c: == Unknown extension ‘6543401’ in context ‘from-pstn’ requested
May 2 13:22:27 DEBUG[4223] channel.c: Scheduling timer at 160 sample intervals
May 2 13:22:27 VERBOSE[4223] logger.c: – Playing ‘ss-noservice’ (language ‘en’)
May 2 13:22:31 DEBUG[4223] chan_zap.c: Exception on 22, channel 3
May 2 13:22:31 DEBUG[4223] chan_zap.c: Got event On hook(1) on channel 3 (index 0)
May 2 13:22:31 DEBUG[4223] chan_zap.c: disabled echo cancellation on channel 3
May 2 13:22:31 DEBUG[4223] channel.c: Scheduling timer at 0 sample intervals
May 2 13:22:31 DEBUG[4223] chan_zap.c: Hangup: channel: 3 index = 0, normal = 22, callwait = -1, thirdcall = -1
May 2 13:22:31 DEBUG[4223] chan_zap.c: disabled echo cancellation on channel 3
May 2 13:22:31 DEBUG[4223] chan_zap.c: Set option TDD MODE, value: OFF(0) on Zap/3-1
May 2 13:22:31 DEBUG[4223] chan_zap.c: Updated conferencing on 3, with 0 conference users
May 2 13:22:31 VERBOSE[4223] logger.c: – Hungup ‘Zap/3-1’

My zaptel.conf file is as follows:

loadzone = us
defaultzone = us
span=1,1,0,esf,b8zs
e&m=1-12

My zapata is :

signalling=em_w
rxwink=150
usecallerid=yes
hidecallerid=no
callwaiting=yes
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=yes
transfer=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=no
echotraining=800
rxgain=7.0
txgain=1.0
group=0
callgroup=1
pickupgroup=1
immediate=no
faxdetect=incoming

;Include genzaptelconf configs
#include zapata-auto.conf

group=2
channel => 1-12

I tried setting up an extension 6543401 to no avail. Any insight on this would be greatly appreciated. It’s a robbed bit non -isdn T1 / wink start


#2

in extensions.conf:

_6543401* => 1,Answer
_6543401* => 2,Playback(tt-weasels)

in zapata.conf

add context=whatevercontext

where whatevercontext is the context that the above pattern match is in…

that should do it.


#3

thanks for the quick response. I setup a context and played around with different settings, the following finally worked. Thank you so much for pointing me in the right direction.

[zap-t1]
exten => 6543401,1,Answer
exten => 6543401,2,Playback(tt-weasels)

You have just savedme from losing more hair. ha !