Inbound fax configuration

I have a fax machine connected to Asterisk via a Linksys SPA3102 ATA. I can now send faxes, but am having no luck in getting the receiving process to work.

I have one PSTN line, connected to Asterisk (I’ve disabled the PSTN on the SPA3102), with the fax number using distinctive ring. I’ve therefore configured dring variables in my zapata.conf (I have configured three, as I see inconsistencies in the dring numbers). I have researched here and on the Wiki and have tried various scenarios, but am unable to get the fax to answer. The last log shows :

hudsonCLI>
– Starting simple switch on 'Zap/4-1’
hudson
CLI> [Dec 22 14:00:03] NOTICE[1457]: chan_zap.c:6367 ss_thread: Got event 18 (Ring Begin)…
[Dec 22 14:00:03] NOTICE[1457]: chan_zap.c:6367 ss_thread: Got event 18 (Ring Begin)…
hudson*CLI> [Dec 22 14:00:04] NOTICE[1457]: chan_zap.c:6367 ss_thread: Got event 2 (Ring/Answered)…
[Dec 22 14:00:04] NOTICE[1457]: chan_zap.c:6367 ss_thread: Got event 2 (Ring/Answered)…
– Detected ring pattern: 389,339,0
– Checking 389,339,0
– Distinctive Ring matched context fax_in
– Executing [s@fax_in:1] Answer(“Zap/4-1”, “”) in new stack
– Redirecting Zap/4-1 to fax extension
– Hungup ‘Zap/4-1’

This seems to indicate that the call is being turned over to the fax_in context, and then being answered by the start extension successfully.

My dialplan for the fax_in context looks like this currently:

[fax_in]
;
; Incoming fax calls directed here by distinctive ring settings in zapata.conf
;
exten => s,1,Answer()
exten => fax,1,NoOp(${CALLERID})
exten => fax,n,Wait(2)
exten => fax,n,Dial(SIP,6003)
exten => fax,n,Congestion
exten => fax,n,Hangup()
exten => t,1,Hangup()

There is a handset attached to the fax machine, and it doesn’t ring, so it is clear from that and from the log snippet that the call is not reaching the machine.

Can anyone shed any light on what I’m missing, or where I’ve gone wrong? I’ve tried a number of different options, based on my research, but none are working.

Thanks,

Des

Hi,

Does anyone have any update information on this subject? Most of my research over the past two days into distinctive rings all has been with the older zaptel driver.

My Asterisk (11.5 running Asterisk GUI) has detects the distinctive rings:
Detected ring pattern: 247,243,216
Detected ring pattern: 337,263,247

By using:

[quote]; Whether or not to do distinctive ring detection on FXO lines:
;
usedistinctiveringdetection=yes
;
; enable dring detection after caller ID for those countries like Australia
; where the ring cadence is changed after the caller ID spill:
;
distinctiveringaftercid=yes
[/quote]

But it is not matched to a CONTEXT even though i have the following in my channels_dahdi.conf

I have the following Contexts listed in extensions.conf

The incoming calls are just routed to the default incoming call group and not the specific extensions.

2 Questions / Issues:

  1. What am i doing wrong as its not phoning the individual extensions? My logs dont show – Distinctive Ring matched context fax_in as the originally message poster log shows.
  2. We have CISCO 7940 series phones. Is there someway to send the Context to the screen on the phone so we know which number the caller has used (distinctive ring)?

Thanks for your assistance in advance!