Ignore SDP Version

Hi guys.

Is there any parameter or set of parameters that have the same effect in PJSIP as ignoresdpversion=yes that exists in CHAN_SIP?

There is no option for that. There are options for specific situations[1][2] however which people have used to resolve some SDP scenario issues. What issue are you encountering?

[1] res_pjsip: SIP Resource using PJProject - Asterisk Documentation
[2] res_pjsip: SIP Resource using PJProject - Asterisk Documentation

Basically, I INVITE the call to the provider, it responds with a first 183 SDP with port 14000, for example. However, later, it sends a second 183 SDP with port 15000 and then comes 200OK maintaining port 15000.
This happens in a few calls, but it occurs considerably frequently and whenever this scenario occurs, the call is muted to the originator.

My provider is not incrementing or changing the SDP version.

Then you’d use the accept_multiple_sdp_answers option I believe, and it also needs to be enabled in the system section too.

Don’t work.


Did you add it to the system section as well, and restart Asterisk?

Yes, I did the restart procedure after implementing the parameter in the system sector.

It also needs to be put in the endpoint configuration as well. Did you do that?


type = aor
contact = sip:X.X.X.X:5060

type = identify
endpoint = provider
match = X.X.X.X

transport = transportudp
type = endpoint
context = newdial
dtmf_mode = rfc4733
disallow = all
allow = alaw
direct_media = no
tos_audio = ef
cos_audio = 5
aors = provider

What you’ve pasted does not show it in the endpoint.

Sorry, I put the parameter in the endpoint sector too and worked now.

Thank you very much.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.