IAX2 error

I’m getting the following when trying to make an outbound iax2 call. I cannot work out what the error is… I’ve removed the telephone numbers appropriately.

Can anyone give me any hints what I should be looking for?


PS: Running Asterisk 1.4.22 on Fedora Core 7


Could you let us see the dialplan. It may be a typo , also do a iax2 show peers to see what is said


Here goes…

Section from extensions.conf

exten => _09.,1,Dial(IAX2/usernameremoved@iax-nursery/${EXTEN},120) exten => _09.,2,Hangup exten => _0.,1,Dial(IAX2/usernameremoved@iax-nursery/44${EXTEN:1},120) exten => _0.,2,Hangup

register => usernameremoved:passwordremoved@voiptalk.org

Appropriate line from “iax2 show peers”

“iax2 show peer iax-nursery”

[quote] * Name : iax-nursery
Secret :
Context : nursery-out
Mailbox :
Dynamic : No
Callerid : “” <>
Expire : -1
ACL : No
Addr->IP : (Unspecified) Port 4569
Defaddr->IP : Port 0
Username : usernamremoved
Codecs : 0xe703 (g723|gsm|g729|speex|ilbc)
Codec Order : (none)
Status : Unmonitored
Qualify : every 60000ms when OK, every 10000ms when UNREACHABLE (sample smoothing Off)

Is the account name iax-nursery ?

If not change the peer name to match the account name.


I’ve now resolved the problem actually making a call, but have now hit a problem with the Codecs, and I can’t work out why.

[quote][Oct 20 20:10:15] WARNING[11487]: codec_gsm.c:144 gsmtolin_framein: Invalid GSM data (1)
[Oct 20 20:10:15] WARNING[11487]: translate.c:211 framein: gsmtolin did not update samples 0[/quote]

I haven’t updated anything since things worked, apart from the suggestions by ianplain. I’ve also tried disabling the gsm codecs both on the IAX and SIP side of things.

Any thoughts?

I’ve now set allow=all in the codecs of iax.conf - quality ok, but using a fair amount of bandwidth.

I know gsm is probably the best, so anything anyone can suggest !!!


Hi GSM may be the “best” when it comes to bandwidth, But Im not sure voiptalk support it. get a few G729 licences and use those.