I have setup voip.ms as SIP provider but can't get calls


#1

while I can make outbound call using voip.ms as SIP carried, I am unable to receive calls, seems like the calls are making their way to Asterisk, but for some reason, it’s not ringin my internal extensio, see below the error I am getting on Asterisk CLI and also my extension.conf

== Using SIP RTP CoS mark 5
[Aug 31 22:05:48] NOTICE[6075][C-0000004c]: chan_sip.c:26265 handle_request_invite: Call from ‘219937_locknetwork’ (192.175.96.69:5060) to extension ‘s’ rejected because extension not found in context ‘internal_users’.
localhost*CLI>

[internal_users]
exten => _1XX,1,Answer()
exten => _1XX,n,dial(SIP/${EXTEN},12,r)
exten => _1XX,n,Voicemail(${EXTEN}@internal-vm)
exten => _1XX,n,Hungup()
;exten => 102,1,Answer()
;exten => 102,n,dial(SIP/102,12,r)
;exten => 102,n,Voicemail(102@internal-vm)
;exten => 102,n,Hungup()
exten => 4443,1,Answer
exten => 4443,n,dial(SIP/4443@voipms)
include => voipms-inbound
include => voipms-outbound

[voipms-outbound]
exten => _1NXXNXXXXXX,1,Dial(SIP/${EXTEN}@voipms)
exten => _1NXXNXXXXXX,n,Hangup()
exten => _NXXNXXXXXX,1,Dial(SIP/1${EXTEN}@voipms)
exten => _NXXNXXXXXX,n,Hangup()
exten => _011.,1,Dial(SIP/${EXTEN}@voipms)
exten => _011.,n,Hangup()
exten => _00.,1,Dial(SIP/${EXTEN}@voipms)
exten => _00.,n,Hangup()

[voipms-inbound]
exten => 9025930158,1,Answer()
exten => 9025930158,n,Dial(SIP/102,12)
exten => 9025930158,n,Voicemail(102@internal-vm)

a debug on SIP shows me the below

<------------->
— (14 headers 0 lines) —
Really destroying SIP dialog ‘083ec69a3859cabf22f603bd6c0c8894@192.168.2.28:5060’ Method: OPTIONS
Reliably Transmitting (no NAT) to 192.168.2.23:64209:
OPTIONS sip:102@192.168.2.23:64209;rinstance=11b6e357e45e7fbb SIP/2.0
Via: SIP/2.0/UDP 192.168.2.28:5060;branch=z9hG4bK7733e16e
Max-Forwards: 70
From: “asterisk” sip:asterisk@192.168.2.28;tag=as0805f70a
To: sip:102@192.168.2.23:64209;rinstance=11b6e357e45e7fbb
Contact: sip:asterisk@192.168.2.28:5060
Call-ID: 42ed455a67399aa32eb7cdd95c7b4b74@192.168.2.28:5060
CSeq: 102 OPTIONS
User-Agent: Asterisk PBX certified/13.13-cert4
Date: Fri, 01 Sep 2017 01:18:24 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE
Supported: replaces, timer
Content-Length: 0


<— SIP read from UDP:192.168.2.23:64209 —>
SIP/2.0 200 OK
Via: SIP/2.0/UDP 192.168.2.28:5060;branch=z9hG4bK7733e16e
Contact: sip:192.168.2.23:64209
To: sip:102@192.168.2.23:64209;rinstance=11b6e357e45e7fbb;tag=6a1a0025
From: “asterisk” sip:asterisk@192.168.2.28;tag=as0805f70a
Call-ID: 42ed455a67399aa32eb7cdd95c7b4b74@192.168.2.28:5060
CSeq: 102 OPTIONS
Accept: application/sdp
Accept-Language: en
Allow: SUBSCRIBE, NOTIFY, INVITE, ACK, CANCEL, BYE, REFER, INFO, OPTIONS, MESSAGE
Supported: replaces
User-Agent: X-Lite release 5.0.1 stamp 86895
Allow-Events: talk, hold
Content-Length: 0

<------------->
— (14 headers 0 lines) —
Really destroying SIP dialog ‘42ed455a67399aa32eb7cdd95c7b4b74@192.168.2.28:5060’ Method: OPTIONS

<— SIP read from UDP:192.168.2.23:64209 —>


#2

The “s” extension is used when there is no known called number in the context used in your case ‘internal_users,

for testing purpose try

[internal_users]
exten => s,1,Answer()
same=>n,Playback(demo-thanks)


#3

It also seems that inbound calls are going to the internal user context. That is dangerous, as contexts with such names can normally make chargeable calls.

The “s” will be because the DID number was not sent by the ITSP.


#4

Thank you guys
so moving forward, what my action should be ?
engage with ITSP and find out why they not sending Called-Number ?


#5

I have used voip.ms you can route the calls to a SIP uri containing the DID you expect to receive

http://wiki.voip.ms/article/Getting_Started


#6

Thank you guys
turn out my voip.ms account was set as ATA when it should be as PBX, I 've set it to PBX and now I am receiving calls.