I can't make a conference room


#1

Hi all, I’ve tried some tutorials about Meetme.conf and ztdummy, and the softphone cannot find the conference room. The result is 404, not found.

Someone can give me tips about this problem ?

Thanks !


#2

I have had trouble with conference rooms to.

exten => 300,2,MeetMe(,DMs) worked for me. The D is to add dynamicaly a conference room. The M is to have moh while the only person in the conference room. It’s actually a pretty nice feature.

exten => 301,1,MeetMe(333) give a error message while I had

conf => 333,M,1234 to prepare for this conference room.

This is the cli output.
Parsing ‘/etc/asterisk/meetme.conf’: Found
– Playing ‘conf-invalid’ (language ‘en’)
== Spawn extension (astlinux, 301, 1) exited non-zero on ‘IAX2/astlinux@192.168.1.106:4569/4’
– Hungup ‘IAX2/astlinux@192.168.1.106:4569/4’

It was just for trying and testing so the first option is fine for me. I’m pretty sure that I followed the book but I give up to get the static conference room working.

I hope my contribution is of some help.


#3

Thanks for the help, but I haven’t done yet.

I’m using the sip protocol and I do not have the zaptel card, I’m using the ztdummy.

I have tried what you did say, but the status when the softphone tries to call is:
404 not found.

When I try in CLI> Meetme, they say that: “No active conferences”.

sip.conf

[myself]
type=friend
username=myself
callerid=myself
secret=myself
context=test
host=dynamic
nat=yes

extensions.conf

[test]
exten => s,1,Wait(1)
exten => s,2,Answer()
exten => s,3,NoOp(${CALLERID})
exten => s,n,NoOp(${CALLERIDNUM})
exten => s,n,NoOp(${CALLERIDNAME})
exten => s,n,Wait(4)
exten => s,n,HangUP()

exten => 1234,1,Dial(SIP/myself)
exten => myself,1,Goto(1234,1)


exten => 300,2,MeetMe(,DMs)

meetme.conf

[rooms]
conf => 333,M,1234

Thanks.


#4

What happens when you call extension 300 . You should enter an ivr that guide you through the proces of starting a conference room, f.i. room 5555 with access code 12345. When starting a conference room you will offcourse be the first to enter the room. Others can enter the conference and than you can start conferencing. When you use the D parameter you don’t need to configure meetme.conf. For conferencing you need ztdummy. You can check this with lsmod on the linux prompt. ztdummy should be in the output.


#5

When I call extension 300 from the softphone the result is 404 not found. I have installed the ztdummy, and they are running in lsmod. But about the ivr, i never had hear about it, ca you give-me some examples ?

Regards !!!


#6

Just add

[300]
exten => 300,2,MeetMe(,DMs)

to extension .conf and and to the default context (assuming that your softphone uses the default context)

include => 300

Instead of 300 you can use any othernumber. This should work. When calling 300 with your softphone you will entere a dialog that asks for a conference number. Because you are start a conference you can pick any number you want or like (2 will do just as 132413413414) and press the # key. Then yu are asked to enter a pincode. If this is not needed you can only press the # key.

check voip-info.org/wiki/view/Asterisk+cmd+MeetMe

run “show applications” on the cli. MeetMe should be in the list.

I hope this helps.