How to setup local "intercom" that can be accessed via ZeroTier vpn

Hi I have been trying for a long time to understand how to setup asterisk so i can use it for old analog phones in the house via a grandstream. I just want a few local sip extensions and being able to also call from my mobile connected via zerotier vpn.

I have got that working when im on a local network, but when i try to connect through the vpn I get no audio.
And then when i try via the local network, it also stops working. So I dont thing my current config anything to keep.

If somebody have a config that can be used for this and would like to share i would be greatfull, or can point to what spesific things i need and why?

Side note I been trying to run it through docker if that makes any differnece

Docker port handling can make a mess of RTP.

Running Asterisk on a RaspberryPi might make more sense for you.

It does, but has an easy workaround. Last I researched Docker networking and UDP don’t play together correctly, and I’ve seen no evidence that things have improved. Run your container with --net=host to take Docker networking out of the equation and you should be fine. I’ve been running Asterisk in Docker with this flag for about 5 years with no issues.

1: Ensure that your Docker container has the necessary network permissions for the VPN and local network. Networking in Docker can sometimes lead to audio issues.
2:Make sure the necessary ports for SIP (usually UDP 5060) and RTP (a range of UDP ports) are properly forwarded in both your local network and VPN settings

Regard
Danish Hafeez | QA Assistant
https://www.ictinnovations.com