How to enable simple features or links

hello everyone,

i purchased the CTI card(TDM400P) which has one fxo and one fxs.
i am able run asterisk and i have one analog phone to it and i have installed softphone also.
using these phones i managed implement the telephony features like CFD ,DND…,
now i have to implement some more features like callpickup,conference etc,
so i need ur help or any links which will help me.

purushi here

now i have a problem in installing mpg123 in FC4
make is not working
i downloaded mpg123-0.59r
when i tried to make its giving this error i have copied only part

-m486’ is deprecated. Use -march=i486' or-mtune=i486’ instead.
gcc -DI386_ASSEM -DPENTIUM_OPT -DREAL_IS_FLOAT -DLINUX -DREAD_MMAP -DOSS -DTERM_CONTROL -Wall -O2 -m486 -fomit-frame-pointer -funroll-all-loops -finline-functions -ffast-math -c -o control_generic.o control_generic.c
-m486' is deprecated. Use-march=i486’ or -mtune=i486' instead. gcc -DI386_ASSEM -DPENTIUM_OPT -DREAL_IS_FLOAT -DLINUX -DREAD_MMAP -DOSS -DTERM_CONTROL -Wall -O2 -m486 -fomit-frame-pointer -funroll-all-loops -finline-functions -ffast-math mpg123.o tabinit.o common.o layer1.o \ layer2.o layer3.o audio.o buffer.o decode_2to1.o equalizer.o \ decode_4to1.o getlopt.o httpget.o xfermem.o decode_ntom.o \ wav.o readers.o getbits.o control_generic.o \ decode_i386.o dct64_i386.o decode_i586.o audio_oss.o term.o -o mpg123 -lm make[2]: Leaving directory/root/Desktop/mpg123-0.59r’
make[1]: Leaving directory `/root/Desktop/mpg123-0.59r’

do u have any idea plz help me
musiconhold is not working therefore i am trying to install mpg123

OK I am not guru, but I can’t see errors.
I can see only warnings.

thanks for ur reply and i tried with other version it worked fine now i have no probs with musiconhold., but clarity is not that much good.

Just curious, do you get an error message when you shut down asterisk?
I was until someone suggested to me not to use mpg123 at all for MOH.

I converted all the mp3 music files to gsm and wav files so I would not need the mpg123 program. It seems to be working great, and it does sound much better for some reason.
You may want to take a look at for more detailed information.

yes i am getting

*CLI> stop now
Beginning asterisk shutdown…
Executing last minute cleanups
== Destroying musiconhold processes
Yuck! Error in buffer handling…: Broken pipe
Asterisk cleanly ending (0).

ok will try your way thanks for ur suggestion

You might want to see the following thread; … usiconhold