How to add P-Asserted-Identity in outbound call

i am trying to add P-Asserted-Identity to outbound call and it failed with below error

can some one help me
extensions.conf
;exten => _!X.,1,SIPAddHeader(P-Asserted-Identity: sip:${CALLERID(num)}\;user=phone)
;For international outbound dialing
exten => _!X.,1,DIAL(${LOCAL1}/${EXTEN})

Using SIP RTP CoS mark 5
– Executing [6166310801@LocalSets:1] SIPAddHeader(“SIP/+14629591001-00000003”, “P-Asserted-Identity: sip:+14629591001;user=phone”) in new stack
– Auto fallthrough, channel ‘SIP/+14629591001-00000003’ status is ‘UNKNOWN’
– Executing [h@LocalSets:1] SIPAddHeader(“SIP/+14629591001-00000003”, “P-Asserted-Identity: sip:+14629591001;user=phone”) in new stack
svtlabaustin*CLI>

You have two Priority 1’s.

Also, the correct way of send PAI with chan_sip is to set sendrpid=pai.

PS Your log contains no errors!

hello John

what would be the solution ?

hi david ,

where can i set the parameters

In the same place as you set any parameter for chan_sip, relating to that peer. See the sample configuration file.

Change one of the priority 1’s into a priority 2 (the one you want executed second). This is very basic dialplan stuff!

thanks David ,

i am new to this so i really don’t know this

i see P-Asserted-Identity: sip:+14629591001;user=phone header constructed like this if i want to add domain to this. how can i add ?
something like P-Asserted-Identity: sip:+14629591001@10.10.10.10;user=phone