Hints are getting stuck (for BLF)


#1

I am using Asterisk 13 and pjsip. I configured my extensions.conf to give the hints and allow extensions/phones to subscribe.

Sometimes hints are getting stuck on the phones if I restart the asterisk or system is idle for a while.
(In asterisk, mostly core show hints shows the proper device_state, once or twice core show hints was also stuck. Asterisk reboot solved the issue but asterisk reboot didn’t help for the phones. The only thing I could do to unstuck the BLF on phone is to reboot the phones.)

Is there a way to force all the phones/extension to reload/restart the subscription for the hints?

Thanks.


#2

There is no ability to do that, generally it’s hard to force phones to do anything. What version of Asterisk is in use? How many hints/subscriptions?


#3

version: Asterisk 13.9.1

Generally, 4-5 hints and 2 subscription per hint. (At max, I will have 20 hints, if I am using the call parking feature together with normal phone system. All the hints related to call parking will have 4-5 subscriptions per hint and other hints would have same setup as mentioned before)


#4

That’s quite an old version of Asterisk, and fixes would have been done since then. I can’t point to any as it’s so old, and it’s not something I’d look into without being on a recent version.


#5

@jcolp, Thanks for your reply. Do you suggest to upgrading to Asterisk 15? or which version would you suggest to use?


#6

Asterisk 13 is still supported, and the latest release of it is 13.23.1.


#7

Ok. Thanks. I will try to upgrade the current system to Asterisk 13.23.1.

What about the newer system which I will be deploying soon? should I still go with 13.23.1 or should I go for asterisk 14 or asterisk 15?


#8

Asterisk 14 and 15 no longer receive bug fixes. The dates for versions and their support time are documented on the wiki[1].

[1] https://wiki.asterisk.org/wiki/display/AST/Asterisk+Versions


#9

Ok. Thanks for the link and information. I will try the set up here with the Asterisk 16.


#10

What phones do you have and what firmware are they on.

If the BLF’s are getting stuck after an asterisk restart then it might be related to my issue.

Yealinks V82+ are following an RFC standard strictly and if you restart asterisk it causes BLF’s to be stuck: https://community.freepbx.org/t/blfs-not-working-right-with-yealink-83-0-x-firmware-response-from-yealink/52012

There is an asterisk bug ticket here if it is your issue, vote for it if it is: https://issues.asterisk.org/jira/browse/ASTERISK-27759


#11

@adtopkek, Thanks for the link.

I am using Yealink (SIP-T29G), Grandstream (gxp3240, gxp2130). I have tried different firmware.

Also, I am using rfc4733 which is defined in the pjsip.conf as dtmf_mode=rfc4733.

How can I vote for it?


#13

Make a JIRA account then there is a watch/vote link on the right “box”.


#14

There is a watch link, but there is not a vote link. There was a vote link, for a while, in the past, but that was turned off because it could give people the wrong impression, since there’s no actual statement about what “voting” meant. The core development team doesn’t work non-commercial issues based on votes.