[Help]problem with make of 1.2 zaptel


#1

I am relative newbie to Linux and Asterisk.
I got Asterisk v 1.0 working with my OEM FXO X100P card.
I decided to upgrade to Asterisk v1.2
I re-formated my Linux partitions and re-installed Mandriva Linux limited edition 2005 and updates
and I thought all the relevent files.
I got Asterisk v1.2 from the CVS plus zaptel etc I tried making zaptel and got the following errors:
/lib/modules/2.6.11-6mdk/build
make -C /lib/modules/2.6.11-6mdk/build SUBDIRS=/usr/src/zaptel modules
make[1]: Entering directory /usr/src/linux-2.6.11-6mdk' CC [M] /usr/src/zaptel/zaptel.o In file included from include/linux/module.h:10, from /usr/src/zaptel/zaptel.c:44: include/linux/sched.h:37:31: rsbac/cap_getname.h: No such file or directory In file included from include/linux/module.h:10, from /usr/src/zaptel/zaptel.c:44: include/linux/sched.h: In functioncapable’:
include/linux/sched.h:942: warning: implicit declaration of function rsbac_cap_log_missing_cap' /usr/src/zaptel/zaptel.c: At top level: /usr/src/zaptel/zaptel.c:176: warning: 'fcstab' defined but not used make[2]: *** [/usr/src/zaptel/zaptel.o] Error 1 make[1]: *** [_module_/usr/src/zaptel] Error 2 make[1]: Leaving directory/usr/src/linux-2.6.11-6mdk’
make: *** [linux26] Error 2

I then went on to make asterisk and that works with a SIP phone.
I believe I must have not installed all the necessary files for the Make of Zaptel.

Can somebody please tell mewhat I have missed?
Thanks


#2

Did you have a look at the readme and do a make for linux2.6?

rgds


#3

Thanks for the quick response

I have the following files installed as requested in what I assume you mean as the Readme under the heading of CVS repository.
I did not think of a make of linux as I used the MDK object last time. Is it necessary?

even-ncurses-2.5.1-6mdk
libncurses-devel-5.4-1.20050108.1mdk
libncursesw5-5.4-1.20050108.1mdk

libopenssl0.9.7-devel-0.9.7e-5.2.102mdk
libopenssl0.9.7-static-devel-0.9.7e-5.2.102mdk
opessl-0.97e-5.2.102mdk

perl-Compress-Zlib-1.37-0.1.102mdk
zlib-devel-1.2.2.2-2.2.102mdk

bison-2.0-1mdk
(this sted only for 1.0.X N.B. I have not got devel installed)

kernel-2.6.11.6mdk-1-1mdk
kernel-i586-up-1GB-2.6.11.6mdk-1-1mdk
kernel-source-2.6-2.6.11-12mdk
kernel-source-stripped-2.6-2.6.11-6mdk

The kernel not mentioned but I reckoned those filles wernecesary