FIXED :: SIP Outbound Dialing Failures, FXS Dialing Perfect

Greetings all:

Proverbial disclaimer: I am relatively new to Asterisk, but yes I have been through the Asterisk Book several times. I am still a novice seeking guidance.

My land line phone dials outbound perfectly, everytime.

My Aastra 9112i dials internally everytime, perfectly.

My 9112i is unable to dial outbound and the CLI at verbosity 10 shows nada…
[globals]
PUBLIC=Zap/4

extensions.conf
[outbound-local]
ignorepat => 9
exten => _9NXXXXXX,1,Dial(${PUBLIC}/${EXTEN:1})
exten => _9NXXXXXX,2,Congestion()
exten => _9XXXNXXXXXX,1,Dial(${PUBLIC}/${EXTEN:1})
exten => _9XXXNXXXXXX,2,Congestion()

sip.conf
[201] ; Desk Phone, Aastra 9112i

type=friend
username=201
secret=12345
host=dynamic
;context=from-sip
dtmfmode=rfc2833
context=internal
mailbox=201@default
nat=yes
canreinvite=no

I do not find any helpfull log files and would be grateful for any assistance!

Thanks,
Ian

your phone starts in context [internal]. does [internal] include [outbound-local] ?

Yes it does. Is it possible that it’s my SIP phone (Aastra 9112i) which is causing the problem?

[internal]
include => outbound-local
include => outbound-ld

; Ian’s Desk
exten => 201,1,Dial(${IAN},10,r)
exten => 201,2,VoiceMail,u201
exten => 201,201,VoiceMail,b201

[outbound-local]
ignorepat => 9
exten => _9NXXXXXX,1,Dial(${PUBLIC}/${EXTEN:1})
exten => _9NXXXXXX,2,Congestion()
exten => _9XXXNXXXXXX,1,Dial(${PUBLIC}/${EXTEN:1})
exten => _9XXXNXXXXXX,2,Congestion()

; 911
exten => 911,1,Dial(${PUBLIC}/911)
exten => 9911,1,Dial(${PUBLIC}/911)

[outbound-ld]
ignorepat = 9

Thanks!

exten => _91NXXNXXXXXX,1,Dial(${PUBLIC}/${EXTEN:1})
exten => _91NXXNXXXXXX,2,Congestion()

UPDATE:

I have modified the dial pattern in my Aastra 9112i and now outbound dialing functions, although I am confused why it did not before.

Dial Pattern was:
[2-9]11|[56]1[1-5]|9[2-9]xxxxxx|9[2-9]xxxxxxxxx|91[2-9]xxxxxxxxx|1[2-9]xxxxxxxxx|011x+#|xx|*xx+#|x+#

Now:
[2-9]11|[56]1[1-5]|9[2-9]xxxxxxxxx|91[2-9]xxxxxxxxx|1[2-9]xxxxxxxxx|011x+#|xx|*xx+#|x+#

Note that the 7 digit dialing was removed. It seems the phone was truncating the dialed digits to 7 vs seeing the 10 digits dialed. Or am I lost somewhere?

Thanks!

if i remember it correctly, a good asterisk dialplan for aastra phones is simply:
x+#
with send dialplan terminator set to no. This will disable dialplan function on the device basically and make whatever you dial be sent straight to the * server with no checking.

the downside to this is if you dial normal numbers they won’t go thru as fast. You can use live dialpad but this will make it match the first pattern it hits…
ie if you have
exten => 8000,1,whatever
exten => 80009,1,whatever
and you dial 8000 it will not wait to see if you are going to dial 9. This can also be worked around by using a send key- ie start dialing, press a line button to send, then pick up the phone. Or pick up the phone, dial, and press right arrow to send immediately.

All,

I have resolved the issue by replacing the dial plan in the phone with:
X+^

and I send the dial plan terminator.

Thanks to all.

Ian