Fedora 5


#1

Can someone help me how to install Zaptel drivers on FEDORA 5? Is that impossible yet?
Thanks.


#2

…Anyone? :wink:


#3

same as fedora core 4, i would assume…

download, decompress, make, make install…

if you’re getting an error, post it.


#4

I’ve tried both to install zaptel-1.2.5-14.1.rhfc5.at.i386.rpm and zaptel-1.2.5-14.1.rhfc5.at.src.rpm (from atrpms.net/dist/fc5/zaptel).

When I try to run “genzaptelconf” in Asterisk@Home (2.8) it says:

It says the same when booting the machine.

When I try to compile the source (i guess it’s located at /usr/src/zaptel?) i get a long list of errors.
At the beginning:

and it keeps saying the same thing down to:


#5

This is a known issue with the latest CentOS 4/RHEL 4 latest kernel and I assume its the same on FC5. See this thread below on how to edit the Makefile for Zaptel to work around the issue.

http://forums.digium.com/viewtopic.php?t=5681

Alternatively you can edit the kernel source as outlined in step “Patch and Compile Zaptel” on the FreePBX setup wiki.

http://www.aussievoip.com/wiki/index.php?page=freePBX-Centos

Scott


#6

Thank you, now it works!
I found a lot of information about this bug before, and I tried to fix it but it seems I didn’t manage to do that until now.

Thank you again!!

Regards - Tomas