Extension and dialplan issues

Hello guys,
In my sip.conf I used static IPs.
my extensions.conf is as follows:

exten => 100,1,No0p(First Line)
exten => 100,2,No0p(Second Line)
exten => 100,3,Dial(SIP/caleb)
exten => 100,4,Hangup

But when I get to asterisk -rvvv and I dial 100, the call doesn’t go through and there’s no response in the asterisk console.

Any assistance from anyone please. Don’t know what I have done wrong

Maybe your sip peers are not registered . What is the output of following command ?

asterisk -rx “sip show peers”

What is the output of “sip set debug on” when you attempt to place a call? (If it is coming in over SIP). If there is nothing then it is likely that the traffic is not reaching Asterisk and you will need to look at the network itself.


sip set debug on

and send the log when you are dialing .

Was that when you were attempting to call into Asterisk? If so then it never got to Asterisk.

This output occurs when I type “sip set debug on”. It also occurs when I reload sip. When I attempt to call no output is displayed.

What is the network topology and are any firewalls or NAT in place? Can the other side get to the Asterisk server? What are you attempting to call from?

Firewall is disabled and NAT is enabled. Both sides can get to the asterisk server. The call is being made from one IP phone to another IP phone.

Could you tell us the output of “sip show peers”?

That is Asterisk sending a SIP message to determine if a remote device is still there. I’m not really sure I have anything else to offer, the calls are not getting to Asterisk.

Could it be that, the IP phones I’m using have static IPs which I guess does not need to register with sip. Because I haven’t registered the IP phones with sip.

Could you please post yout sip.conf?

It looks OK. What happens if you use dynamic IP?

It works. But when my internet goes off and comes back on assigning my phones new IPs, peers suddenly becomes unreachable. Just don’t know why?

Have fixed it. It was an issue with how the network was setup. That was why the calls were not getting to asterisk.
Thanks a lot guys