Executing bash script


can anybody help me with the following problem?
I want to perform a shell script on calling an extension.
When I call the number in Asterisk- CLI with console dial 1100@phones the script is executed and I can use also the log-App to log to messages. But when I make the same call from a sip-client in the same context phones, neither logging is working nor the script is executed.
I used SHELL and System(), both work only from a console dial.
Asterisk is running as user root and version 12.4.
I use the absolute path to the script and the script-file has 777 and the super user flag set.
What I’m doing wrong? I’m getting crazy because of the problem.
Thank you in advance for your help.


The dialplan should be thoroughly decoupled from the source at that point, so I don’t understand this behaviour. You need logging, starting at verbose 5, and possibly going up.

When I run asterisk -rvvvvvv I can’t see anything when I make a SIP call from my mobile (Linphone-App) which is connected via WLAN. But the call is established with another locally run linphone-client on the asterisk-machine (raspberry-pi) at port 5070. Asterisk runs on port 5060.
When I make a console dial I can see the verbose()-messages in CLI or the logs in the messages-file.
How can I debug?

The SIP call is going nowhere near Asterisk.

But in my linphone-client-app there’s the proxy asterisk-server port 5070. And I can see sip register commands when I turn on SiP-debugging. But it is strange…I can’t see an Invite-Message?!

The contact header on the invite response is probably wrong, or the response is not getting back to the phone.

You gave me a great idea! I just captured the sip packets with tcpdump…and found out that linphone sent the Invite-Message directly to the port of the other client running on the same machine as asterisk. So it bypassed asterisk. Linphone configuration the port in the app only changed the local sip port. So now I changed the ports on my raspberry: asterisk now 5060 and linphone 5070 and it works!

Thank you very much!