Err attended transfer

Hi,

I have a problem with assisted transfers, I have this error.

My features configuration
[general]
pickupexten = *8
atxfernoanswertimeout = 15
atxferdropcall = no
atxferloopdelay = 10
atxfercallbackretries = 2
atxferabort = *1
atxfercomplete = *2
atxferthreeway = *3
atxferswap = *4
[featuremap]
blindxfer => #12#
disconnect => *0
automon => *1
atxfer => 2#
parkcall => *7
automixmon => *3

In both the dial and queue applications, the parameters of T and t were configured.

endpoint 10001 configuration

100rel : yes
accept_multiple_sdp_answers : false
accountcode :
acl :
aggregate_mwi : true
allow : (alaw|opus)
allow_overlap : true
allow_subscribe : true
allow_transfer : true
aors : 10001
asymmetric_rtp_codec : false
auth : 10001
bind_rtp_to_media_address : false
bundle : true
call_group :
callerid : soporte4
callerid_privacy : allowed_not_screened
callerid_tag :
connected_line_method : invite
contact_acl :
context : clients
cos_audio : 0
cos_video : 0
device_state_busy_at : 0
direct_media : true
direct_media_glare_mitigation : none
direct_media_method : invite
disable_direct_media_on_nat : false
dtls_auto_generate_cert : No
dtls_ca_file :
dtls_ca_path :
dtls_cert_file : /etc/asterisk/---------
dtls_cipher :
dtls_fingerprint : SHA-256
dtls_private_key : /etc/asterisk/----
dtls_rekey : 0
dtls_setup : actpass
dtls_verify : Yes
dtmf_mode : auto
fax_detect : false
fax_detect_timeout : 0
follow_early_media_fork : true
force_avp : false
force_rport : true
from_domain : --------
from_user :
g726_non_standard : false
ice_support : true
identify_by : username,ip
ignore_183_without_sdp : false
inband_progress : false
incoming_mwi_mailbox :
language : es
mailboxes :
max_audio_streams : 1
max_video_streams : 1
media_address :
media_encryption : dtls
media_encryption_optimistic : false
media_use_received_transport : true
message_context :
moh_passthrough : false
moh_suggest : default
mwi_from_user :
mwi_subscribe_replaces_unsolicited : no
named_call_group :
named_pickup_group :
notify_early_inuse_ringing : false
one_touch_recording : false
outbound_auth :
outbound_proxy :
pickup_group :
preferred_codec_only : false
record_off_feature : automixmon
record_on_feature : automixmon
refer_blind_progress : true
rewrite_contact : false
rpid_immediate : false
rtcp_mux : true
rtp_engine : asterisk
rtp_ipv6 : false
rtp_keepalive : 0
rtp_symmetric : false
rtp_timeout : 0
rtp_timeout_hold : 0
sdp_owner : -
sdp_session : Asterisk
send_connected_line : yes
send_diversion : true
send_pai : false
send_rpid : false
set_var :
srtp_tag_32 : false
sub_min_expiry : 0
subscribe_context :
suppress_q850_reason_headers : false
t38_udptl : false
t38_udptl_ec : none
t38_udptl_ipv6 : false
t38_udptl_maxdatagram : 0
t38_udptl_nat : false
timers : yes
timers_min_se : 90
timers_sess_expires : 1800
tone_zone :
tos_audio : 0
tos_video : 0
transport : transport-wss
trust_connected_line : yes
trust_id_inbound : false
trust_id_outbound : false
use_avpf : true
use_ptime : false
user_eq_phone : false
voicemail_extension :
webrtc : yes

Many thanks in advance

In future, please provide logs as the actual text, preferably taken from the relevant log file.

Your first two warnings indicate that you haven’t correctly installed the standard sound files.

See the source code comments for the third message:

1 Like

Thanks a lot! I have created the audio of pbx-transfer and it seems that it already works, Why the audio affects the execution of the transfer?.