Enabling AES_256_GCM encryption suite

Hello Everyone,

I am trying to enable the AES_256_GCM crypto suite on asterisk 18. I tried below things but didn’t work. Can some one help me on that.

  1. CFLAGS=‘-DENABLE_SRTP_AES_GCM’ ./configure (It is enabling 128 bit GCM but not 256)
  2. CFLAGS=‘-DENABLE_SRTP_AES_256_GCM’ ./configure(Not working)
  3. CFLAGS=‘-DENABLE_SRTP_AES_GCM_256’ ./configure(not working)

Please let me know using which flag we can enable the AES_256_GCM crypto suite.

According to the source code I believe it would be:

1 Like

Its working !! Thankyou

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.